Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 96 impala SS and I have to direct wire the fuel pump to work under the hood To make the fuel pump work I am love on that can someone tell me what to do to make the fuel pump come on when I turn on the ignition well it does prime when I turn on the Key and start it it try’s to run but once I hook the wire up underneath the hood it runs fine can some one tell me my problem
 

·
Registered
Joined
·
246 Posts
Lack of punctuation...

have you checked the fuses and or the relay that goes to the fuel pump since the pump runs when you power the wire that tells us that the ground is good at the pump/tank so you could power this wire again and then use a test light to see where you don't have power coming back to the underhood fuse block and relay to help narrow down the problem it could be a lot of things but check the simple stuff first
 

·
Registered
Joined
·
972 Posts
PCM powers coil on relay to prime fuel pump oil pressure switch powers fuel pump when oil pressure pressure gauge on fuel rail will tell much sound of fuel pump not good enough even if engine runs
 

·
Registered
Joined
·
246 Posts
Here's the schematic to get started.

Do you have power on both sides of Fuse #2?
Do you have power at the DK GRN/WHT wire when the engine is running?
Do you have ground on the other side of the DK GRN/WHT wire (F11 BLK)?

If the answer is "no" to any of the above - fix that

 

·
Registered
Joined
·
330 Posts
Check your oil pressure switch. It is a safety circuit to shut off the fuel pump if the engine is not running. Seems like your engine starts but won't keep running unless you "force" the pump to run. But beware, you might not actually have any oil pressure and indeed, the engine should shut off. Good luck.
 
1 - 5 of 5 Posts
Top