Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
I thought it may have been a burnt bulb but when I replaced with a new one, the light still didn't work. Wires look ok and I jiggled them to see if the contacts with the connector were loose but still no workie. I was going to check the fuse but couldn't find which one the glove box is wired through. Scratching my head on this one.​
 

·
Registered
Joined
·
6,802 Posts
Courtesy lights (I believe)...
 

·
Registered
Joined
·
8,059 Posts
A few:
See can you disassemble the switch for anything corroded/broke/worn.
If not takeapartable then some spray elec contact cleaner
If nonathat then glop the switch full of dielectric grease and cycle 100x
Or, try to order a new switch


You didn't list your car, but some Cadys/Buicks have extra special CCM (I think Computer Convenience Module?) that controls many of the options and cause wonky symptoms when going south (though I can't believe they'd include the glovebox light on it). In any case check around for any other lights not working that might give hint of upstream circuit for more burnt fuses.
 

·
Registered
Joined
·
6,802 Posts
How 'bout checking for power,and ground presence before screwing with switch.
 

·
Banned
Joined
·
3,437 Posts
I thought it may have been a burnt bulb but when I replaced with a new one, the light still didn't work. Wires look ok and I jiggled them to see if the contacts with the connector were loose but still no workie. I was going to check the fuse but couldn't find which one the glove box is wired through. Scratching my head on this one.​

you fix the pass key mess ? what about the glove box ///. what is going on ?
 
1 - 8 of 8 Posts
Top