Chevy Impala SS Forum banner

1 - 20 of 246 Posts

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #1 · (Edited)
Continuing where I left off in this thread: http://www.impalassforum.com/vBulletin/showthread.php?t=232657&page=15

Decided to start a new thread for the whole project instead of continuing in my engine thread in the engine section.

Just a little breakdown on the car:

Forged 9.4:1 355ci with unported aluminum heads
Comp 224/224*, 0.575" lift and 113* LSA cam.
Twin T3/T4 50mm turbos

Hughes Performance competition prepped TH400 with transbrake and Pro Series billet 10" converter.

3.23 gears in stock housing with Eaton LSD, disc brakes, UMI control arms and LCA relocation brakets.

Denso 300lph in-tank pump, Kenne Bell Boost-a-pump, 63 lbs injectors and dual-feed fuel rails, F.A.S.T engine management.

Now for an update!

The wiring is 99% done! The complete harness is installed, I wired the LTCC in there and all looks almost facotry now

All I have to wire is the starter and the battery cables.

I changed the brake prop and meetering valves and bled the lines.

The Hughes TH400 and billet converter are installed.

I modified my fuel sending unit wiring so I now have 2 dedicated wires going to the fuel pump instead of using the stock harness with tinny wires. I have a 8awg wire going to the Kenne Bell BAP and 12 AWG wires going from the BAP directly to the fuel pump... shouldn't have any problems with fuel pump voltage now! cwm7 So that's done and the tank is on the car.

Exhaust system is also installed.

Left to do:

Fabricate a coolant expansion tank and heater hoses.
Vacuum and boost reference lines, boost pressure regulator, boost switches (for water/meth injection and BAP)
Install transmission cooler
Cold side piping modifications and installation
Get a driveshaft made
Install battery and cables, alternator, water/meth injection system, misc accessories, etc...

Comments, suggestions and questions are welcome :)

Here's a few pics

TH400:


Torque converter:


Engine pic from last week:
 

·
Registered
Joined
·
442 Posts
very cool cant wait to see your times!
 

·
Registered
Joined
·
578 Posts
Nice build, From the pic you posted the wiring looks real good, Can't wait to see pics of the rest of your build and hear Hp/Trq #'s . Thanks for sharing your build. Please keep us posted.

Thanks
 

·
Registered
Joined
·
407 Posts
Looks very, very nice! Glad to see your progress. What exactly did you do to the sending unit to add the second wire? Also, how close are the coils to the hot side of the turbos/WGs/DPs? Any overhead pics of that or of the sending unit?
 

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #5 ·
I drilled the top plate and installed a grommet for the 2 wires that power the fuel pump. Sorry no pics of that. The fuel level sensor is still plugged like it was from the factory.

The coils are 4-6" away from the hot side. I'll get a better pic of the coils.
 

·
Registered
Joined
·
407 Posts
I drilled the top plate and installed a grommet for the 2 wires that power the fuel pump. Sorry no pics of that. The fuel level sensor is still plugged like it was from the factory.
I think that some f-body guys had some trouble with pump cavitation when they added wiring to the pump due to the wiring not being sealed. I believe it had to do with the fuel tank not staying pressurized.
 

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #10 ·
I think that some f-body guys had some trouble with pump cavitation when they added wiring to the pump due to the wiring not being sealed. I believe it had to do with the fuel tank not staying pressurized.
hmmm... i'll have to look into that :confused:
 

·
Registered
Joined
·
407 Posts

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #12 ·
My fuel cap hasn't made that hissing sound for years now... :p

I'll try it as is, and see what happens. cwm7
 

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #14 ·
IT'S ALIVE!!!! :D

idles and runs really smooth, cant wait for the snow to melt :)
 

·
Registered
Joined
·
4,532 Posts
SSSSick
 

·
Registered
Joined
·
190 Posts
IT'S ALIVE!!!! :D

idles and runs really smooth, cant wait for the snow to melt :)
i m unpatient to make a try of that rocket......then i am unpatient to try mine too!! :):):)
 

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #18 ·
pic updates plz

Meh, doesn't look all that good right now... The wirring harness doesnt have the plastic loom over it because I want to be able to work on it easily.

The piping is painted and will stay that way until it's 100% final.

...and it's really dirty cwm5

I might post a pic anyways, just to show the progress :)
 

·
Registered
Joined
·
1,252 Posts
Don't rush it!! Slow and right is faster that quick and wrong, its cheaper also.

You'll get there!!
 

·
Registered
Joined
·
4,532 Posts
When ever I get the mid project blues
It's time for the Cure

step 1: Shopping
-sawzall blades
-notorn 40 grit friction wheel
-new spool of MIG wire
*trip to the store gets you mind off of whats in front of you at the moment

step 2: Minds Eye / Visualization
-crack open a cold beverage
-stand in front of the car
-stare down the car with roll of blue painters tape and silver sharpie at hand
-let your mind go free, your past the point of no return!
-mark up your changes in blue painters tape and sharpie
*maybe even cardboard and painters tape!

step 3: Action
-change what bugs you with the car
if it takes 10 times longer to change the car to make it 1% easier to work on
Do iT!

if it takes 10 times longer to change the car so you dont cring when the hood goes up
Do iT!
 

Attachments

1 - 20 of 246 Posts
Top