Chevy Impala SS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
I have a hard start issue in my 96 impala, but the car runs and idles great !

performed a pressure test

switch on 45 psi.
car on 45 psi
car off 45 psi and drops very slowly..

took off the vacuum hose off the FPR and no fuel trace.

new fuel filter with new spark wires

will be changing the spark plugs soon..

any help ppl
 

·
Premium Member
Joined
·
2,547 Posts
What's the condition of the coil; OEM?

Have you cheked spark discharge?
 

·
Premium Member
Joined
·
2,547 Posts
I got one of these from Amazon a while back.





It makes things a little easier. If you have an extra plug & wire, disconnect the wire coming out of the coil. Then attach the extra plug wire, and plug, and then ground the extra plug wire, and have a friend turn over the engine a few times, and look for a strong spark.

If ya don't have any extras, remove one from a cylinder and ground the plug, and have a friend turn the engine over.

Look for spark again.

Tell us how the spark seems to be.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #6 ·
I did the spark test and there was a good one. I took off the coil wire and gave it a good clean with WD-40, and it just fixed it and it fires up from the first start ,, will keep monitoring it for a couple of days and see if that solves the problem
 

·
Registered
Joined
·
581 Posts
If WD-40 caused the car to start up easier, I recommend using a generous amount of dielectric grease on all ignition wires. It will help prevent moisture from dissipating the spark before it reaches the plugs. - Peter
 

·
Premium Member
Joined
·
2,547 Posts
Could certainly be the coil. You did replace the coil wire in addition to the 8 spark plug wires when you installed new ones, right?

What some folks have done on the coil is, space it away from the heat of the cylinder head by installing a few flat washers on the back side, between the coil and the cylinder head. This keeps the coil from getting constant heat from the head.

If ya have to replace the coil, I'd do that while you're in there.
 

·
Registered
Joined
·
3,096 Posts
The problem is back again. I guess that the coil is weak and need to be replaced !

what do u think guys
I had your exact problem once and it turned out to be the coil. You say you have spark, but it has to be a very strong spark on all cylinders, not just a test of 1 or 2. If you have strong spark it is not your coil.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #11 · (Edited)
Well all the wires R new... Some times I have to prime the fuel pump several times and it fires up but some times it doesn't work.....also if I shut off the engine,the pressure decreases slowly and after like 5 mins it reches 30psi, should the car keep pressure or lose when it's off?
 
1 - 11 of 11 Posts
Top