Chevy Impala SS Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter · #1 ·
my 96 ss takes awhile to start. it will turn over for about 6 or 7 seconds maybe longer then it will finally start. ive replaced the fuel regulator opti spark all plugs and wires. brand new distributor cap rotor everything. it has gas in it. and while its turning over u can smell gas and once it finally starts its flooded of a second burning off all the fuel that was dumped in the engine while turning over. anyone have and ideas
 

·
Registered
Joined
·
3,094 Posts
Have you done a fuel pressure test and changed the fuel filter?
 

·
Registered
Joined
·
576 Posts
If you're sure the fuel pressure is right and based on the other stuff you've done, I'd start looking at your injectors for leak down or incorrect spray/clogs.

Just out of curiousity, what spark plugs did you use?

Does it run well otherwise, once started?
 

·
Registered
Joined
·
285 Posts
I'm having the same issues...I had my mechanic change the fuel pump in april- he changed it again yesterday(GM pump both times). The Impala will hold pressure for about a half hour then it loses pressure and becomes hard to start.
Frustrating!
 

·
Registered
Joined
·
1,729 Posts
check your fuel pressure regulator, even if you changed it, if you can smell fuel the diaphragm inside of it might have gotten damaged.

pull off the vacuum hose from the end of it and check for sign of fuel, if you can smell/see fuel from that end your regulator is shot.

a bad regulator will cause the exact symptoms you are describing.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top