Chevy Impala SS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
So like the title says, my headlights have been flickering off and on with heavy bumps or braking. Light braking and little dips here and there don't do anything. But a hard enough stop, even on a smooth rode, will cause my lights to go out momentarily, then they will turn back on. Im running HIDs with a really harness, and doubt it's the dimmer switch b/c this didn't start happening till after I put the relay harness in. Could this be a ground or power issue? Everything on the harness looks good and tight, but I did have to replace 2 dimmer switches before finally putting the relay. no other lights go out besides my headlights. I would really appreciate any help with this because I can't seem to find an answer, and this is the 2nd time this has happened to me and unfortunatly both times were at night On my way home from work.
 

·
Registered
Joined
·
11,207 Posts
You could have either a power or ground issue. Because it only happened since you installed the relay, I would suspect that area. It is hard to determine what the issue is, because it only happens in a dynamic setting. You need to check each connection for tightness, and check the relay for its ability to absorb a shock load. The relay could have a loose internal connection.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
Finally had the chance to take out my battery and have a good look. Found a cut up wire hidden underneath the tray, getting chopped up by a sharp edge on the battery tray... Had a cousin help me move the wires out the way while I placed the battery in when I was installing my relay. What great help he ended up being lol .. spliced it together and bought a battery hold down so I never have that problem again.. I was lucky my lights were turning on at all
 

Attachments

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Thanks for the help btw
 
1 - 4 of 4 Posts
Top