Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I am a new owner of a 95 Impala SS with 60k miles and new to this forum. I know that there are some issues with the 4spd auto from time to time - Mine is running fine, just wondered what to look for in case I do experience any problems.

Cheers in advance:):D
 

·
Registered
Joined
·
3,505 Posts
At 60,000 you shouldn't have any problems. Change the fluid and filter at the presribed intervals, don't "flush" it. It's a good idea to tighten up the shifts for longer life via either a performance tune to the PCM or a Transgo Shift kit.
Good luck.
 

·
Registered
Joined
·
3,096 Posts
At 60,000 you shouldn't have any problems. Change the fluid and filter at the presribed intervals, don't "flush" it. It's a good idea to tighten up the shifts for longer life via either a performance tune to the PCM or a Transgo Shift kit.
Good luck.
There is considerable disagreement on the issue of "don't flush". That is an old rumor long ago discredited with solid evidence. The flushing procedure in the sticky mentioned is very good. See the excellent post by Ghetto Wagon in this thread:

http://www.impalassforum.com/vBulletin/showthread.php?t=251170&highlight=flush&page=2
 

·
Registered
Joined
·
3,505 Posts
"That is an old rumor long ago discredited with solid evidence."

There are plenty of people who can provide just as much "solid evidence" of trans failure within a short time after flushing.
 

·
Super Moderator
Joined
·
8,908 Posts
moderator comment

Guys, don't start the argument here. Go post on the appropriate existing threads.

Meanwhile, read that thread with all the stickies!
 
1 - 7 of 7 Posts
Top