Chevy Impala SS Forum banner
1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
The power antenna in my 96 DCM is freaking out ! After a short ride, it refused to go down when the car was off, I went outside and started gently pushing it to see if it was just stuck. It would only go down if it was turned (rotated) slightly. BUT...the motor continues to run, even tho the keys are out of the ignition and everything. I'm here at work, I'm in my dress clothes and it's about 95 outside...

I've got 1 more hr. of work: When I get home, what do I need to disconnect/unplug. I tried every fuse in the side fuse panel and nothing worked...HELP.


Update..got it to stop running...I just have to leave the key in the ign. with the radio on. Please...how can I fix !
 
G

·
Discussion Starter · #2 ·
seems to me like a case of old antenna (tm). probably the little plastic strip inside the antenna is cut in half or something like that. It is really troublesome to get to the antenna motor. You need to remove the front quarter panel somehow. Maybe somebody here knows a little more about this.
 
G

·
Discussion Starter · #3 ·
Hi guys-
I believe UZ is correct( internal damage to the antenna).To stop the motor disconnect the three wire plug in the engine compartment leading down into the fender.
(white grn and black If I remember correctly)
Leave it in the up position until you can repair it... not fun. I think you need a specific mast socket and then you will need to unbolt the lower edge of the fender and carefully remove the unit for repair.
Been a while since I had to do one on a GM car.
-Scott
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top