Chevy Impala SS Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter · #1 ·
Hello everyone im new to the forum and i need some advice.... i have a 1994 chevy impala ss and i find that my cooling fans do not turn on, even tho my car dont over heat but i noticed my temperature hits 3/4 and still no fans. i take car to midas and they tell me my cooling fan relay is bad and it needs to be fixed, and it cost $265!!!! wow so i go to auto parts store and buy the two relays for cooling fans thats located in fuse box under hood, and still fans dont turn on.......im not a auto tech and im need of some help, any advice is useful thanks
 

·
Registered
Joined
·
3,612 Posts
Unplug the ECT sensor at the front of the water pump with the engine running. Both fans should come on within 30 secs. If not, swap the fan relays and see if it follows the relay. If so, replace the bad relay. If not, check for wiring issues. If none, replace bad fan motor.

Midas is trying to screw you bigtime. The relay is proabably $10 and the labor is 10 seconds.
 

·
Registered
Joined
·
5,693 Posts
Check the fuses also....DUH. Cheapest thing's first.
 

·
Registered
Joined
·
1,437 Posts
I had the same problem, first try what the one guy was saying about unpluging the sensor at the water mump or you can also turn your AC on and fan number 2 should turn on but for me it turned out to be a bad fan motor which was fairly inexpensive.
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #6 ·
thanks guys for info im going to check wiring first then go from there ill update here to teel you guys what was actual problem
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #7 ·
Oh and i took out relay in fuse box and the primary fan one side of fuse was kinda melted and u can see it in fuse box like the plug in spot was burnt and melted........does that mean theres a short in the wiring harness?
 

·
Premium Member
Joined
·
2,327 Posts
I did the external relay years ago due to the fuse/relay block being burnt. You can do it your self for $10 if you need all the parts or just order the kit.
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #11 ·
i changed the relays bought 2 brand new ones from auto parts store, fans dont come on so now it narrows to wiring harness or fan motors itself, how much does a fan motor normally run?
 

·
Premium Member
Joined
·
2,327 Posts
Got a meter or a test light? Check for voltage at the plug first. Junkyard fan should be $15-$25. I don't care for any of these auto part store fan motors.
 

·
Registered
Joined
·
5,693 Posts
i changed the relays bought 2 brand new ones from auto parts store, fans dont come on so now it narrows to wiring harness or fan motors itself, how much does a fan motor normally run?
Did you unplug the ECT on the front of the water pump to check?
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #14 ·
ummm i dont wanna sound extra newbish lol but where is the ect sensor, is there a picture to point it out? sorrry im not mechanically sound
 

·
Premium Member
Joined
·
2,327 Posts
ummm i dont wanna sound extra newbish lol but where is the ect sensor, is there a picture to point it out? sorrry im not mechanically sound
Here you go:

 

·
Registered
Joined
·
586 Posts
Discussion Starter · #16 ·
i unplugged sensor and fans kicked right on, but i also noticed my fans was coming on when the ac compressor tried kicking on, but it wud cut on and off then i hear this loud hiss somewhere under the accumalator so i found out why my ac was blowing cold because i have a leak.....
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #17 ·
ok i see leak and its under accumalator it looks like this seal but a fat seal on this bar lol sorry i really dont know what it is, but now i wonder how much will it cost to repair the leak?
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #18 ·
so now that fans have turned on, then im guessing there is nothing wrong with the harness or motor or relays now, is the problem the ac compressor?
 

·
Premium Member
Joined
·
2,327 Posts
Can you post a picture where the leak is at?
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #20 ·
heres a vid link on youtube on where my leak is i dont kno why it doesnt have sound tho lol but right where my finger is pointing is where loud hiss noise and i can see some kind of fluid or oil drip there

 
1 - 20 of 30 Posts
Top