Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,451 Posts
Discussion Starter #1
2 weeks ago my mirror fell off the windshield and was hanging by the wires---for about a week. Both lights in the mirror were off at that time. While prepping to glue it back on I plugged the wire connector in and one light stays on all the time and the other will not come on at all. Sooooooo I took it apart and didn't really find anything and then I dropped it and well that mirror is now in the land fill. So I buy another mirror from Mr. Impala Auto Parts. This mirror does the same thing. 1 light in the mirror stays on and the other won't come on at all. Is the problem in the connector and wire that goes back up under the headlinner. Can someone point me in the right direction to fix this?
 

·
Registered
Joined
·
1,451 Posts
Discussion Starter #3

·
Registered
Joined
·
1,094 Posts
That was my best guess from what you wrote. You still will have to close the doors and check. I like the probable solutions first. You could have a shorted switch and a open switch but most switches get very little use and should be fine. It would seem near impossible to have four switches fail.

I cannot see a way that the wiring harness could cause your issues.

The only bulb information I found was this:

http://www.impalassforum.com/vBulletin/26-electrical/273223-passenger-map-light-not-working.html

#73 seems right. T9 torx will be a pain.

Before I would buy a new bulb I would check the old one. You could use a ohmmeter or switch the placement of two bulbs.

I am sure most people have a story where they took a part something several times before finding out that they forgot to do something to make it function "normally".
 

·
Registered
Joined
·
1,451 Posts
Discussion Starter #5
Guess what? After I shut the car door and plugged in the mirror---it works But I have to replace 1 bulb. Thanks for the link to do just that!
 

·
Registered
Joined
·
1,451 Posts
Discussion Starter #7
1 - 8 of 8 Posts
Top