Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,418 Posts
Discussion Starter · #1 ·
Question: I recently swapped out my HIDs as the ones I had went bad. I replaced the whole kit and bulbs. Maybe I'm losing my mind but the current low beams look like the old high beams and the current high beams look like the old low beams.

I thought if I unplugged the battery and hit the high low switch once and then plugged the battery back in it might work but it didn't.

Only other thing I could think of would be if I reversed the high low wires but from what I remember those are shaped so you can't plug them in backwards. I'll check this tomorrow in the daylight.

Unless anyone has any suggestions, I might just take out the high beam indicator bulb on the dash...
 

·
Registered
Joined
·
2,418 Posts
Discussion Starter · #2 ·
I think I might know what is wrong. I found this.



My only question is....

On the car itself. the recieving end of the plug is
Black
White
Dark Green

but on the kit the wires are

Brown
White
Blue

I wonder why these are so different from the above picture as I bought the kit from DDM

Currently the white and blue wires are switched from the above pictures so I will swap them tomorrow which I would imagine has to work.
 

·
Registered
Joined
·
6,949 Posts
They don't look right cause they're not designed for our headlights. The hi/lo switch on HIDs doesn't change the pattern, the bulb moves just enough to change the pattern. I notice no difference when driving with them on hi or lo.
 

·
Registered
Joined
·
399 Posts
I had the same problem with my HID kit. Low beams only worked and the brights indicator was always on. The blue connector wires need to be switched. There's a thread on here that shows the switch.
 

·
Registered
Joined
·
2,418 Posts
Discussion Starter · #5 ·
I had HIDs before I recently installed a new kit so I remember what the old low with HIDs looked like. One of the ballasts went bad and I couldn't find kit was previously installed as the kit had no markings on it at all. There is a noticeable difference between my high and low beams as far as spread of the beam (not light output)

My lights are obviously switched as this morning on my way in to work I was behind a nice shiny car so while I was waiting I switched my headlights a few times and could see in the reflection that when the headlights are on "low" they are in the top portion of the headlight and as I turn on my high beams, they move to the bottom portion of the headlight.

I'll switch the wires around this afternoon and see if that works.
 

·
Registered
Joined
·
757 Posts
Yes this worked. Low beams are now lows and high beams are now highs.
I'm installing a DDM Hi/Lo kit too and just had a question on the wiring. Should it be Blue, White & Brown?
 
1 - 8 of 8 Posts
Top