Chevy Impala SS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Hello all--a few of you may remember me from a series I penned at Winding Road magazine a couple years ago on my 1994 Buick Roadmaster sedan experience:

http://www.windingroad.com/articles/blogs/flip-this-car-1994-buick-roadmaster/

Well, I just couldn't stay away. Today I picked up another 1994 Roadie, only this time I went with the woody estate. I'm a complete wagon junkie and I've been wanting one of these for awhile now. This time, however, I won't be writing about it (officially anyway) with plans to rallycross it and eventually sell it. I plan to keep this one around for awhile.

It's a work in progress, It's running and driving alright for now but I do have some engine issues. Seems the electric fans are always on, there's a slight stumble/drop in power when I tip onto the throttle, and it feels a bit down on power in general compared to my sedan. The previous owner said the trans was rebuilt 6000 miles ago, also had lots of brake work done recently. It seems to drive well, it's nice and clean inside, the outside isn't terrible but the wood trim and side mouldings definitely need redone. It will be a good machine to work on piece by piece through the winter.

It's showing 139,000, and I scored it for $1550. Compared to that sedan I wrote about back in 2010, I'm already well ahead of the game.

Pics to follow soon. It's the standard dark blue w/ woodgrain, blue leather interior, all stock. It has a belt driven fan so I'm assuming that means it has the towing package? I'm sure I'll have some more questions in the weeks/months/years to come. Admittedly I got a bit tired of the sedan, but I'm such a wagon nerd that I see myself getting way too carried away with this one.

Anyway, good to be back into a B-Body!:)
 

·
Registered
Joined
·
1,146 Posts
Your fans could be an easy fix. There is a sensor on the water pump. If it is unplugged, both fans will come on. Plug it back in.

Tom
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
That's very interesting because I get no temp reading from the water pump when I go into the diagnostic mode on the climate control. Thanks!
 

·
Registered
Joined
·
236 Posts
I bought a 94 caprice with the same transmission problem as your sedan once, thanks to this board I found out it was the ECM, got a remaned one from gm and had it programmed and life was good.
 
1 - 4 of 4 Posts
Top