Chevy Impala SS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I'm new here. I have a 1994 Caprice 9C1 which had a presumably malfunctioning cluster. The speedometer and odometer would flicker or go out completely, with the odometer giving erratic and random numbers. But always the trip meter would stay lit. I tried the fix of pulling the display and reflowing the connections on the back of it, and it made no difference. I then had an electrical engineer(employee of friends father) check it out and he said there was nothing wrong with the cluster itself. Me being stubborn went and bought a known good cluster, but it does the same thing. My question is, is there a next step or any thing outside of the cluster itself that could cause this? I have no other issues electrical or otherwise with the car.

Thanks in advance.
 

·
Premium Member
Joined
·
90 Posts
agrajag,

Hey there, welcome to the forums. As far as I've read around these parts, bad grounds in these cars can cause a seriously long list of funky electrical issues. (I'm currently wrestling with many of them myself as I chase down crafty electrical gremlins in a car of my own.)

There are multiple grounds in the engine bay - near the ignition coil, near the battery, behind the engine to the firewall, and others. There's also at least one ground in the trunk.

I'd start by making sure these have good, clean connections without broken wires. Hope that helps you take a step in the right direction!

-ETS
 

·
Registered
Joined
·
339 Posts
When you say you replaced the cluster, do you mean the entire cluster, gauges and all, or just the little display board?

The dimmer circuit could be causing you grief, though it's odd the trip part of the display lights up.

Remember that the 9C1 had a button on the dash to kill the display so you could sit in stealth mode. That part of the circuit could be misbehaving as well, except the trip part again.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top