Chevy Impala SS Forum banner

1 - 6 of 6 Posts
T

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I installed belltechs and Spring-Techs in the back.. the goddamn spindal connection to the control arms in the front doesn't come off... I wacked the bastard for 30 minutes with a 20 lb hammer. Damn Mid West car is rusted (Underneath it has that Z-bart so the body is fine). I can't do anything. Tried lubricant, IDEAS Please?
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Put the car on the ground, stuff a piece of 2x4 between the upper control arm and frame so it can't drop.
Now jack up the car by the frame or crossmember (jack stands are a given)so the spring is trying to pull the joint apart.
Loosen the nut about two turns ONLY and give the casting a wap right near the taper.
Gerry
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I did all that and wacked it for like 30 minutes and it didnt come loose. Sometimes I admire European my friends' bmws... ****s so simple
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I actually used an old bottle jack when I changed my spindles on an mini truck I used to have. I put it in between the upper control arm and lower arm and jacked it apart. Just be sure not too loosen the nut too much as mentioned above. When it "popped" , it was surprising! Careful!
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Do what gerry said... Its worked every time for me!!!
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #6
got frustrated and gave it to a shop. Honestly you would think that on a big car like ours there would be plenty of room to work.
 
1 - 6 of 6 Posts
Top