Chevy Impala SS Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
1,316 Posts
Discussion Starter · #1 ·
The LT1 in my 95 Caprice has an intermittent problem with how it runs. At times it will run great and have lots of power, other times it will run rough and looses power. It definitly feels like a cylinder is cutting out. If you are driving you can feel it all of a sudden have no power and run like crap, then the power just comes back like you hit the gas. The PO had his mechanic look at it and says an injector is going, how would I go about testing to find out which one? I was going to just pull one spark plug wire at a time, but its almost impossible to do this on this engine without getting burned.
 

· Registered
Joined
·
701 Posts
If you can catch it in the act of running rough, you can pull the injector connectors one at a time. The suspect injector would make no difference in the engines roughness if it is an injector. (healthy injectors when unplugged will cause a noticeable miss) Thats worked for me before, but its not really a true test.
 

· Registered
Joined
·
1,316 Posts
Discussion Starter · #3 ·
I thought I figured out which injector it was, when it was running rough, unplugging the suspect one made no difference. I went and swapped that one with another working one on the car. Now when it runs rough and I unplug the cylinder which was bad (known good injector in it), it still makes no difference. Unplugging the thought to be bad ones makes it run worse. So Its probably not the injector. I installed a test light on the harness and it appears fine, even after wiggling the cables. I am gonna replace the plug and wire for that cyliner, if that doesnt work, could the opti be bad?
 

· Registered
Joined
·
701 Posts
If you change the spark plug and wire and nothing improves, its possible the opti is on its way out. Another quick test, and i know of one person who had this happen, is to thump the pcm while its acting up. Its rare, but something inside (injector drivers?) can go bad and thumping the pcm will cause a change in the behavior. The fix for this scenario is a new pcm. Thats about all i got on this one, gremlins often stump me. EDIT- Before starting the opti rnr, id take the ICM to your local parts store to have it tested, its free, and its easy to pull it.
 

· Registered
Joined
·
1,316 Posts
Discussion Starter · #5 · (Edited)
Would the PCM from my 95 RMW be the same for testing purposes?
EDIT: If I need the opti, wheres a good place to get a new one?
 

· Registered
Joined
·
701 Posts
Would the PCM from my 95 RMW be the same for testing purposes?
EDIT: If I need the opti, wheres a good place to get a new one?
It will work. The best place to get the opti is thepartsladi on ebay. Around $250 for the good oem opti, and dont forget the opti vent harness, and the front cover seals, because oil will do a number on the new opti if the seals arent changed. The WP seal can be tricky, keep the inner seal lip turned inward by using the WP coupler with a piece of 20oz drink bottle wrapped around it to help slide it onto the WP drive gear.
 

· Registered
Joined
·
1,316 Posts
Discussion Starter · #7 ·
Some good news. I had a chance tonight to swap out the plugs. The PO had the car tuned up about 3 months before the tranny went and the mechanic had replaced the plugs and wires. I pulled the old plugs, and replaced them with fresh delco plugs. Before I did that I noticed cylinder 2 (the one I was having trouble with) only had the plug finger tight, litterally. Tightening it did nothing to fix my problem. The plug looked like crap compared to the other cylinders. Anyway, I got them all in, and she fired right up and runs strong! I took her for a drive for a good 15 miles and all seems well (except the tranny, but thats another project for another day).
I question weather the mechanic did all the plugs or not, the passenger side had new looking bosch plugs, the driver side had slightly used champions. I also found 4 used delco's in the back of the car. At any rate, the LT1 runs great! Thanks for the help
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top