Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a 94 impala SS with a rebuilt engine at 108000 and now I'm at 136000. I ok recently I just put on a new water pump, distrubutor and temp sensor. I drove 400 miles from DC to Columbus, Oh without a problem. Once I got here one day my car cut off while I was doing 40. I pulled over and it restarted without incident. Later it cut off again I had to restart it 3 times just you get it off the street. When I restarted it I would run for a second then just die. I thought it had low oil so I put some in let it cool then it started and got me home. I check the throttle body for obstructions... nothing. I checked the vacuum hose... nothing. I thought it may be my fuel pump but it doesn't seem to be the problem. When I start it I hear a motor winding but engine it won't turn over and if it does it'll cut off either smoothly or violently. I took it to a mechanic he said it was my tps and my IAC. I went to the junkyard and found one of each from a roadmaster. I put it on started her up it sounded great for about 15 seconds then it cut off. I'm at a total lost. Then I thought it might be the idle air control valves so I bought those and installed them. Now its got like no power when it finally does start it like takes a lot of gas to do anything. Help me brothers.:confused:
 

·
Registered
Joined
·
9,682 Posts
Is the check engine light on? What kind of opti did you use? If it was a cheapo ebay or parts store opti, that is most likely your problem. You also need to verify fuel pressure with a test gauge. There is a test port on the fuel rail (in back of the intake manifold on passenger side - near firewall) Just because you can hear the pump run, doesn't always mean it's putting out enough pressure to run the car. With a gauge hooked up, turn the key on and it should register at least 38lbs (typically between 38-43lbs) Anything lower, then you got problems...
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Bad Distributor

Checked fuel pressure it was good. Computer is reading a bad distributor. Anyone know a good one around american made only please.
 

·
Registered
Joined
·
1,040 Posts
I got mine from when Dal was around, my buddy on here got his off ebay from thepartsladi. It is a good distributor made by delphi, forgot the price though, but works great.
 
1 - 5 of 5 Posts
Top