Chevy Impala SS Forum banner

1 - 7 of 7 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I am looking to upgrade my 9c1's am/fm with the above mentioned unit. It's $130 on crutchfield.com

My needs are very basic and am only looking for a decent system. Is anyone using it, and what are your opinions of it?

After the head unit, then I'll be upgrading the speakers...

Thanks.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #2
OK, no comments. How about any of the other low end models?
Kenwood KDC217
KDC2019

Pioneer DEH-1400
DEH-2400F

Anyone???
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I've used many Kenwood electronics (amps head units) and they have never failed me. I am using currently an 8 year old amp that has been ripped out of a car (attempted to be stolen), pos and neg terminals touched a couple of times, and wrong load (1 ohm impedance when set up for 4 ohm) and this amp is still kickin hard.

I stand by Kenwood electronics, for sure. I will go out on a limb and say that that head unit is great, based on their reputation and my experience with their stuff.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Thanks BC.

It's official. Kenwood enjoys a %100 approval rating!*



*Approval rating based upon those who responded.
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #5
How about Alpine? Just had a Kenwood crap out in my Z71 GMC yesterday after only about 2 1/2 years. Never had a problem with Alpine systems.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #6
I've always used Kenwood head units. I have always loved them. I have had about a dozen or so, since I started driving. I have built a few competition level systems with them too. I actually just bought a Kenwood eXcelon KDC-459. I got it brand new for $169 on Ebay. It's a great unit and it very upgradable. It has 3 sets of pre-outs, built in crossovers, multiple EQ settings. I would highly recommend it.


 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #7
About Alpine. I Had an alpine CD player in my Crown Vic. I did have a problem with haveing to turn the sound up to a certain level so my left channel would come on. I did not have to turn it way loud but it was still somthing that I felt kinda sucked. I sent the unit away 2 times to get it fixed under warenty and it never came back any better. I also had a problem with the lights burning out on the faceplate. I sent that in about 2 times as well. But that problem was fixed both times. It took at least 2 weeks each time I sent it in for repair. 2 weeks my not seem like alot but try not turning on your radio for 2 weeks when your driveing around. Plus do you know how many times I reached for the empty hole in my dash to turn the radio on?

But on the up side. The unit sounded great. In my opinion, Alpine has the best looking stuff. And the controls feel alot better than most other decks. I have gotten tons of use out of the deck. 100K miles worth of music and it is still going strong (minus a light or two in the face plate). It now resides in my mothers company work truck.

Could I have gotten a lemon? Thats entirely possable. But I think I want to try my luck with another brand. I am leaning tward a Kenwood MP3 player to go in my 9C1. Sorry it's so long but I hope that helps.
 
1 - 7 of 7 Posts
Top