Chevy Impala SS Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Knightshade wrote:
<BLOCKQUOTE>quote:</font><HR>Sadly due to work I can't make it to events that are much further than Atlanta... I should be at SSHS3 if nothing else and would be happy to chat with ya.<HR></BLOCKQUOTE>

I moved this over from a post that got locked because I wanted to ask you about your fuel system. I noticed you upgraded your pump and injectors. Did you see any gains from that or was it a security move?

I'm asking because our cars are very similar, ported iron, 845 cam, high stall. And i'm considering upgrading my fuel system if it will help me.

The fuel system is about the only thing on the car I haven't messed with... so i figure it next.
 
G

·
Discussion Starter · #2 ·
Chris,

When I ran the 845 cam on a set of ported iron heads, the stock injectors were maxing out around 6000 rpm. I upgraded to 30# injectors and everything was fine for a while, until my fuel pump started to wear out. Upgraded to the Walbro 340 and the car ran great from then on.
 
G

·
Discussion Starter · #3 ·
Ditto. Saw from the track data I was slightly beyond the stock fuel system, knew I wouldn't be modding to the point I needed an uber-fuel system like SSMOKEM for a long time, so I went with the 30s and Walbro, no problems with fuel since.
 
G

·
Discussion Starter · #4 ·
I'm trying to work on what looks like a misfire on the dyno sheet. My HP and TQ curves are squigly lines above 5000 rpm. My opti, wires and plugs are all pretty new. However, the Dyno sheet shows my air fuel ratio very steady at 13 with only slight vairiations. I guess Ill try a new opti first.... but I'd like to do the fuel system too.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top