Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
435 Posts
Discussion Starter #1
Hello friends!

During Christmas break I probably put around 2,500+ miles on Carl and he held up just fine. Drove from Portland down to Sandy Eggo and back up again, drove to the coast and the mountains a few times, etc. etc. Needless to say, with all the driving- you're bound to notice a few things here or there. While coming back down the mountains without using any throttle, I noticed the RPM's dropping in an almost rhythmic pattern. I was just curious if anyone else has encountered this? I've included a shot video of this happening. Nothing out of the ordinary happening as far as driving though. Still running like a champ besides a leaking PS system, lol. The ABS light is on because of the staggered tire setup. Hope you all are doing well this new year!


 

·
Registered
Joined
·
1,389 Posts
Not sure if it's the same, but my 91 has always done something similar or same. As i pull into a long exit ramp coming off the highway and lift off, you feel the engine braking, but then a few seconds maybe, it lets go and feels more like neutral. Been doing that for all it's 250k+ miles.

Now thinking about it, on the long deceleration coming off the bridge, it does the same but braking kicks back in and then out till i need to hit the gas again. So maybe same after all.
 

·
Banned
Joined
·
3,437 Posts
never seen that rpm drop going down a grade no throttle.could be tranny is changing from lock up to unlock .. torque converter .
 

·
Registered
Joined
·
10,920 Posts
That is the torque converter unlocking. Both of mine always did that.
 
1 - 5 of 5 Posts
Top