Chevy Impala SS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
looking for some help here guys decided to lower the car with some sprint springs and the car had a lil vibration before but nothing that was bothering after lowering car i took it for a spin and accelerating 45-50mpg it has this shake this is getting into gas a little more then half throttle. it also did it on deceleration at the same speeds. Speeds lower then what i have listed you dont feel it and once you get to highway speeds you do not feel it either. Could i have a driveshaft issue here? tires arent of brand but have good tread 15" .
i dont feel it in steering but i do feel it in my a$$ and its also noticable that the driver side headlight is shaking as well.

any help would be great
 

·
Registered
Joined
·
108 Posts
Discussion Starter #2
"This was before lowering car"
i also would like to add that i also noticed that the previous 2 times i removed driveshaft i had noticed it was hard to pull out. the first was to do the gears i lifted rear of car let rear hang removed ujoint straps and pried forward thinking i would get the usual give forward a lil and nothing i ended up having to put trans in nuetral and remove both ujoint caps and rotate shaft in order to free it from pinion. the second was when i dropped trans to install convertor with front of car up in the air i removed u joint straps and driveshaft would not come forward only like 1/2" i had to pull off ujoint caps and rotate shaft with trans in nuetral in order to get it out of the pinion...

could my driveshaft be to long to begin with???Then with the lowering of the car it runs the shaft even deeper into the trans. This is the first time ive had this issue. forgot to mention the hassle with the driveshaft but i feel its important
 
1 - 2 of 2 Posts
Top