Chevy Impala SS Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
OK today as i was driving to work my imp started to make this loud clanky noise coming from the front tire, passenger side. i roll the window down to hear the noise more careful and it sound like soumething broke. 2mins later i got to work look underneath couldnt see any damage of any sort. this is the second time this has happend. the first time i notice the bump stops were worn out i replace those but it is still there this time not sure what the hell it is??? help :confused:
 
G

·
Discussion Starter · #2 ·
Could be a lot of things best to get it up in the air an inspect it before it leaves you stranded or worse yet in an accident ..... then again it could be something minor.
 
G

·
Discussion Starter · #3 ·
Check to see if your upper control arm shims are still there on each side. If they're not there, then you will get a clunking noise mainly on turns.

Jose
 
G

·
Discussion Starter · #4 ·
yeah i think i will but its strange it comes and goes so i dont know where to look. i guess whatever looks broke huh.
 
G

·
Discussion Starter · #5 ·
the shims are just the rubber inserts right? never really mess with the arms before. if they are pretty much gone are they easy to get or it is a dealer thing.??
 
G

·
Discussion Starter · #6 ·
OKAY i check today and i couldnt find anything the shims are there. I decide to go to a shop and get it lift up to lget a better look. the bushing are pretty bad and my ujoints are also in need of replacing. Plus one bearing was making noise. DAMM when it rains.... :mad:
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top