Chevy Impala SS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
I got a 96 SS BBB LT1...I started the car and it fired right up after a few days of sittin....I warm it up a bit and decided to rev the engine....now when i do that, the RPMs fall under 1000 feeling like it almost shuts off but goes back up again to 1000; but not every time i rev the engine... anyone know? I remember some time back, I got off the freeway and had to brake quickly and my car just lost rpms and turned of...but turned right back on..:confused:
 

·
Registered
Joined
·
3,088 Posts
Way too vague.....could be anything... Fuel pressure? opti? overheating coil ?

do some diagnostic work, like reading the stickies in this and the concerns section.

-ALF out....
 

·
Banned
Joined
·
3,437 Posts
I got a 96 SS BBB LT1...I started the car and it fired right up after a few days of sittin....I warm it up a bit and decided to rev the engine....now when i do that, the RPMs fall under 1000 feeling like it almost shuts off but goes back up again to 1000; but not every time i rev the engine... anyone know? I remember some time back, I got off the freeway and had to brake quickly and my car just lost rpms and turned of...but turned right back on..:confused:

best to check fuel pressures with a gauge on the fuel rail. need 40 psi key on engine off min....that good then it can be an ignition or vacuum leaks .
 

·
Registered
Joined
·
5,693 Posts
Sounds like my car just before the FP quit. Anything above high idle and it would quit.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top