Chevy Impala SS Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey, new member and owner of 96 ss. im installing a viper 5904 and have it wired up thanks to 94mi9c1 diagrams and other members posts on here but I'm stuck now. i have searched everywhere and cant figure it out. alarm activates and sounds but wont lock or unlock the doors or trunk. on 94mi9c1 diagram it showed the green and blue lock /unlock wires being positive and on the viper paper work it shows them as grounds. has anyone had any success with the 5904 or have any suggestions? thanks for your help in advance.
 

·
Premium Member
Joined
·
2,542 Posts
You may try and PM 'Hack' (Scott Williams) and see if he would be willing to hep you out.

Scott used to own AudioFX in Georgetown & Austin TX, and installed the remote start system in my Tahoe.

He has since sold the business, and is now doing stuff with 4X4s, but you can try hitting him up and ask if he can assist ya, if someone here doesn't have the answers you need first.
 

·
Premium Member
Joined
·
8,383 Posts
I am digging into it right now, but Hack may have the quick answer. With a short search what I am finding is the door lock/inlock triggers on the newer versions of alarms are only negative triggers, when previous years it would alternate those outputs between power and ground. When hooking up the wiring to the door lock/unlock relays you shouldn't need an external relay, but if the alarm is only outputting ground for lock/unlock you will have to add a relay to actuate and pass power to the door lock/unlock relay to trigger the locks.

The diagram that I made for the install is based on type A locking system, which our cars have and based on this guidance from Directed http://kb.directed.com/Attachment184.aspx

I am going to call a buddy that owns a shop this morning and find out if directed changed the system where you need a relay that passes voltage to trigger the factory locks.

I will let you know.
 

·
Premium Member
Joined
·
8,383 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #9
WOW, I can't thank you guys enough for all this help. I did use the revised A and hooked up the red/white to the black/white under the dash. I'll take a look at that this morning.
 

·
Premium Member
Joined
·
8,383 Posts
No worries, look at revision A that you have, on the last page it shows red/white to relay. That will take care of the trunk, waiting on a call back from my guy at the audio shop, but I would think after reading the installation manual that it doesn't do positive output for the type A door locks anymore, relays will have to be put in, but I will confirm and let you know.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #16
well followed your advice and threw in some relays and that solved my door problem. didnt realize the no help for non dealers after i bought it but oh well, you guys saved me. huge thanks. so for the future, 5904 needs relays.
 

·
Premium Member
Joined
·
8,383 Posts
No worries man I will put that in the drawing when I get a chance. glad it was an easy fix. And Directed has always been that way, you have to give dealer number to get to tech support. Most likely due to liability issues, etc.
 

·
Registered
Joined
·
1,034 Posts
I would think that you can tie any siren that you want to the system, the six tone is just internal to the siren itself. The siren just generates the tone off the trigger that it receives from the alarm module.
Thanks, I had the horn done vice the played out siren. I do have a problem, It wont let me remote start it with the alarm engaged. All I get is a short "click" followed by the alarm going off displaying a trunk opened trigger. The trunk isnt even wired up yet. It starts while unlocked though? I get a few miss fires here and there when remote starting. never had a problem with direct key turn though.
 
1 - 20 of 24 Posts
Top