Chevy Impala SS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1 (Edited)
Hi guys, still putting together a 1996 SS Impala that was torn apart 10 years ago and left by a mechanic that screwed me over, and was garaged ever since.



I got the car running and driving with help from a friend, but the whole upper air intake was ripped off including the Mass Air Flow Sensor and thrown away when he ripped it up for an installation of a Raiss Ram Air Cold intake, to attach to my Ram Air Hood.

I also just bought a new Mass Air Flow sensor and a dual cone cold air intake, but I didn't install the Raiss chrome plate/shield under.


My problem now is where do all these air hoses (pictured under) go on the new cold air intake and what do these plugs go to, what’s missing? There are 3 openings on the new cold air intake pipes, one on the back of the passenger side pipe (pictured under) and 2 on the driver side (pictured under), There are 3 hoses not connected to anything but I believe only 2 connect to the cold air intake and on the passenger side a sensor must go there. I don't know what goes to what exactly, because I didn't take off the original air intake,


The car is slipping now with high RPM's like something is holding it back. The transmission was fine prior to the engine being torn up. I've been reading it could be due to these hoses and the cold air intake.


Any help would be great, thanks.
 

Attachments

·
Registered
Joined
·
5,708 Posts
Pic one: into the intake in between the MAF and the TB, prob in the hole in pic 5 (was in the rubber elbow stock)

2. Air pump (probably deleted on this car)

3. AC compressor (I think you can actually see the connector lower in that pic!)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
Pic one: into the intake in between the MAF and the TB, prob in the hole in pic 5 (was in the rubber elbow stock)

2. Air pump (probably deleted on this car)

3. AC compressor (I think you can actually see the connector lower in that pic!)

Still confused, there no holes in between the MAF and Throttle body and which hose of the 3? How about the other 2 hoses and the white adapters on the passenger side of the cold air intake pipe?



And on the plug on pic 3, I was thinking that could be a plug for an air temp sensor that's missing and that goes into that passenger side pipe on pic 5 but idk?
 

·
Registered
Joined
·
2,906 Posts
Hi, the 3 holes in the dual cone setup for white plastic holes should be
A. the Opti vent hose, you are holding it in pic 1 [blue tip on end of hose] goes on small white plug on DR side
B. IAT intake air temp sensor [Pass side hole with block rubber grommet]
C. Air hose that would have gone to AIR PUMP [ other white plug on DR side]

I'll have to dig more for the Pass side hole in pic 5 == IGNORE this statement.

-ALF out...

EDIT: thank you Sinister for joggin my memory
link to pic of my car you can see the 3 items
https://photos.app.goo.gl/G7kgcDqkyHbaxnRT9
 

Attachments

·
Registered
Joined
·
3,632 Posts
Picture number one is the Optispark vent harness. The blue elbow goes into the intake tubing. On yours it should plug into that small white nipple. The hose with the extra piece of rubber on it goes into the bottom of the Optispark (Distributor) the other plugs into the center of the left hand side of Intake Manifold.

Picture 2 is Air Pump plug, yours looks like it is gone so just wrap it with some good tape.

That large white nipple in your air intake is for the Air Pump, again yours is gone so it needs to be plugged off somehow.
 

·
Registered
Joined
·
327 Posts
I think pic 3
Shows the connector to you air temperature sensor which plugs into the grommeted hole in pic 5. IMHO....

Pic one: into the intake in between the MAF and the TB, prob in the hole in pic 5 (was in the rubber elbow stock)

2. Air pump (probably deleted on this car)

3. AC compressor (I think you can actually see the connector lower in that pic!)

Still confused, there no holes in between the MAF and Throttle body and which hose of the 3? How about the other 2 hoses and the white adapters on the passenger side of the cold air intake pipe?



And on the plug on pic 3, I was thinking that could be a plug for an air temp sensor that's missing and that goes into that passenger side pipe on pic 5 but idk?
Hi, the 3 holes in the dual cone setup for white plastic holes should be
A. the Opti vent hose, you are holding it in pic 1 [blue tip on end of hose] goes on small white plug on DR side
B. IAT intake air temp sensor [Pass side hole with block rubber grommet]
C. Air hose that would have gone to AIR PUMP [ other white plug on DR side]

I'll have to dig more for the Pass side hole in pic 5 == IGNORE this statement.

-ALF out...

EDIT: thank you Sinister for joggin my memory
link to pic of my car you can see the 3 items
https://photos.app.goo.gl/G7kgcDqkyHbaxnRT9
 

·
Registered
Joined
·
327 Posts
You are absolutely correct in that idea. That’s exactly where the air temp sensor goes in pic 5.
Pic 1 is absolutely the Optispark vent line that needs to be drilled in some replacement elbows, but in your case goes to small nipple on driver side.
Block off the big nipple on the driver side if the actual air pump has been removed.

Pic one: into the intake in between the MAF and the TB, prob in the hole in pic 5 (was in the rubber elbow stock)

2. Air pump (probably deleted on this car)

3. AC compressor (I think you can actually see the connector lower in that pic!)

Still confused, there no holes in between the MAF and Throttle body and which hose of the 3? How about the other 2 hoses and the white adapters on the passenger side of the cold air intake pipe?



And on the plug on pic 3, I was thinking that could be a plug for an air temp sensor that's missing and that goes into that passenger side pipe on pic 5 but idk?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8 (Edited)
Hi Guys thanks for the reply’s, I was not able to get back to the car due to cold weather at the time I posted this, and now I’m able to work on it again tomorrow.

So my Air Pump is gone, so the harness needs to be taped up and I have no idea what to use to plug up the large threaded white hole on the CAI tubing, I need to figure that out.

The Blue nipple on the hose I have in my hand needs to come off and needs to be attached on the thin white nipple on the CAI tubing.

The other Harness goes to a Air Temp Sensor (I Need To Buy) and plugs into the black rubber hole on the passenger side CAI tubing.

Now for the other 2 hoses in my hand, I’m a little confused. One goes to a vent on the Optispark at the bottom & the other goes to the center left of the intake manifold?

I don’t know which one is for the Opti & for the Manifold and someone said the left side of the intake manifold middle, so left side of the car or looking at the manifold left side?

Here is 2 pictures of what I’m thinking.
 

Attachments

·
Registered
Joined
·
40 Posts
Discussion Starter #9
Anyone able to chime in on the last post I made? About to start figuring this out in the next hour.
 

·
Registered
Joined
·
8,461 Posts
the one with the blue elbow nipple goes to intake elbow but on your aftermarket thing there should either be a hole for it or a nipple on your intake that the hose would attach.

The 2 other ones go to the 2 nipples on the bottom of your Opti. You will see the larger diameter goes on the larger nipple on opti

That circle you have on the PS of the intake is for HVAC and also EVAP hose to the other one on that side
 
1 - 11 of 11 Posts
Top