Chevy Impala SS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
902 Posts
Discussion Starter · #1 ·
i bought a new crank pulley off of rock auto (ATP Part # 102056) and after about 400-500 miles with it on i noticed it'd taken off about 2mm of the width of the belt, and when i took it off and measured it with the old pulley, it looks like the new one holds the belt about 2.5 - 3 mm closer to the timing cover than the original one did.

when i click the part number on rockautos site, it lists it as being for B and D bodies, as well as F bodies. i thought the F bodies had a different pulley though... or is that just the vettes, and this is just a matter of "you get what you pay for?"

anyone else had trouble with this "Graywerks by ATP" pulley? and has anyone had any better luck with the Dorman one, Part # 594017 (only other one they list for my car)
 

·
Registered
Joined
·
902 Posts
Discussion Starter · #4 ·
sounds like you have a 94/95 hub on a 96, the 96 has a crank reluctor for the crank sensor thats why its shorter
alright that makes some sense, thanks

I have a doorman replacement (I believe) from AZ and i have not had any problems lately. You didn't place the old with the new when you were replacing them?
i set them next to eachother when i took the old one off and eyeballed it, but i guess i didn't look close enough :-(

maybe in the future i'll bust out the micrometer before installing new parts

hopefully rockauto lets me return this thing... the old squeaky one's driving me nuts
 

·
Registered
Joined
·
849 Posts
I am sure they will. My brother ordered an ignition coil from them and it took 2 weeks before he had a chance to install it and it was the wrong coil in the box he ordered (it had 3 pin holes in the tower and not 4). So they shipped him a new one and of no charge,except shipping to there.
 

·
Registered
Joined
·
902 Posts
Discussion Starter · #6 · (Edited)
Just re-read Mean SS's post and realized i misread it the first time i think. I never removed the hub, same one that originally came with the car. The pulley/harmonic balancer was the only thing i changed

so would the pulley be any different between 95 cars and 96 as a result of that, or are the accessories placed differently on 94/95 cars?

rock auto seems to think i put it on backwards which i seriously doubt

Hello Steve,

I did speak with the tech people at ATP - sorry it took a bit of time to play
telephone tag with them - and they suggested that either of two things are
going on.

Either the balancer was installed without the reinstallation of the hub spacer
that goes underneath the balancer - which, candidly, they doubted would even
be possible) or the balancer was installed backwards. They confirm the part
to be correct to the LT1 engine used in the SS, and that the part should be
dimensionally correct to the vehicle.

As it did mount up properly, it seems unlikely that this was a misboxed part.
But the center spokes are not equally offset from one side to the other, so
mounting the part backwards would change the offset of the pulley.

If we may be of any further assistance, please call our customer service
number listed below or just reply to this email.
grrrasdfasdfasdfasdf

Is it possible I got a vette one? or is the difference more significant than 2.5 mm between them and the B/D/F body pulleys? i'm starting to think manufacturer defect. last time i go for the cheapest part i guess :-(
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top