Chevy Impala SS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
629 Posts
Discussion Starter · #1 ·
I have read several times about hissing when you remove your gas cap. All of my LT1 cars do this except my 1995 Fleetwood. If there is no pressure buildup should there be any concern? If so, what could be the problem. I have already swapped gas caps with a car that builds pressure and no pressure.
Thanks
 

·
Registered
Joined
·
216 Posts
I have read several times about hissing when you remove your gas cap. All of my LT1 cars do this except my 1995 Fleetwood. If there is no pressure buildup should there be any concern? If so, what could be the problem. I have already swapped gas caps with a car that builds pressure and no pressure.
Thanks
I would expect there to be an EVAP code set. One of my 1995s has an EVAP issue -- code is set, and there is no pressure in the tank.
 

·
Super Moderator
Joined
·
6,000 Posts
The first check they do for an emissions test is to check for the cap holding pressure. Automatic fail if it doesn't hold. Just replace your cap.
 

·
Registered
Joined
·
629 Posts
Discussion Starter · #5 ·
I have already tried several caps that from my other cars that do hold pressure, no luck. No codes have been set. Any other ideas?
 

·
Registered
Joined
·
731 Posts

·
Registered
Joined
·
9,682 Posts
Check the vent hose where it connects to the sending unit at tank. The hose has a history of popping off. You should be able to see it if you jack the rear of the car up and look underneath right in front of the gas tank.
 

·
Registered
Joined
·
342 Posts
I also am getting a large pressure buildup...it seems to blead off for a good 4 to 5 seconds. Anybody have any ideas?
 
1 - 9 of 9 Posts
Top