Chevy Impala SS Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,542 Posts
Discussion Starter #1
Just putting a feeler out there to see if anyone has had any similar experience..

I'm not getting a signal/voltage down at the wiper fluid motor. The motor is good, when I apply 12 volts directly.

I replaced the turn signal stalk a few years ago. At the moment I don't recall what the problem was with the OEM unit.

Just wondering if there is anything else I can look into for the problem?
 

·
Registered
Joined
·
7,988 Posts
At least you know the pump motor is good and can back track from there. I'd be checking the schematic for the pump circuit and back tracking from there. Most likely just a simple wiring issue.

http://www.goldsswagon.com/diagrams/impala_wipers.pdf

Looks like its controlled through the Wiper Motor which I guess is triggered via the stalk. Check for continuity going from the pump (2 wires) to the wiper motor. Consider the problem could also be in the wiper motor module as well.
 

·
Registered
Joined
·
11,219 Posts
I would suspect the wiper module on the wiper motor. Check your Red and Dk Blue wires to the washer motor, and the Pink and Gray wires from the stalk, to the module.
 

·
Premium Member
Joined
·
2,542 Posts
Discussion Starter #4
At least you know the pump motor is good and can back track from there. I'd be checking the schematic for the pump circuit and back tracking from there. Most likely just a simple wiring issue.

http://www.goldsswagon.com/diagrams/impala_wipers.pdf

Looks like its controlled through the Wiper Motor which I guess is triggered via the stalk. Check for continuity going from the pump (2 wires) to the wiper motor. Consider the problem could also be in the wiper motor module as well.
I would suspect the wiper module on the wiper motor. Check your Red and Dk Blue wires to the washer motor, and the Pink and Gray wires from the stalk, to the module.
Thanks gents. I posted this when I first got up today, and then looked over the FSM schematic over breakfast.

I was surprised to see that the signal comes out of the wiper motor, but after thinking about it I understand completely.

That'll be tonight's project.
 
1 - 4 of 4 Posts
Top