Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
429 Posts
Discussion Starter · #1 ·
Guess I should post this in the drivetrain section too:

Haven't been able to figure this out. The car has delayed shifts and absolutely will not shift into 4th from time to time. This happens about every other day to and from work. If I turn the car of for a few minutes, then turn it back on it shifts perfect thru all gears and drives great. I have no idea what the deal is. What's weird is this only happens 25% of the time.:confused:

Anybody have any ideas? I'm going to Autozone later to see if they'll scan for me
 

·
Super Moderator
Joined
·
8,898 Posts
Probably electrical. I'd check and/or replace the Throttle Position Sensor first, then start looking for electrical problems in the transmission wiring harness or solenoids. All of the electronics inside the 4L60E can be accessed through the pan, without removing the transmission.
 

·
Registered
Joined
·
429 Posts
Discussion Starter · #3 ·
Thanks Sherlock. I'm going to go get a new TPS since there not that much. Hopefully that works, but if not post back here since I know nothing about transmissions.

On another note, I found out no one will scan for trouble codes on an OBD1. The mechanic I usually do to wanted $75. I migh as well buy the labtop cable.
 

·
Registered
Joined
·
2,187 Posts
Thanks Sherlock. I'm going to go get a new TPS since there not that much. Hopefully that works, but if not post back here since I know nothing about transmissions.

On another note, I found out no one will scan for trouble codes on an OBD1. The mechanic I usually do to wanted $75. I migh as well buy the labtop cable.
Who's no one? Did you try Autozone, Advanced, O'Reilley's, or Napa? I'm pretty confident that they do them for free.

-Mike
 
1 - 5 of 5 Posts
Top