Chevy Impala SS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
I had a leak coming from this area not too long ago. I solved the problem with the GM gasket and o-ring kit right here, which was relatively painless. A couple weeks went by and the leak came up again in the same place. I know it's only coming from the adapter as I've been able to locate it to that exact spot.

When I took the adapter off the first time, I noticed an orange gasket that seemed to take the place of the o-ring. I figured that someone must have taken the gasket from an oil filter and used it in the o-ring's place. Now I'm wondering if that orange gasket should have been left in place. Keep in mind, there was no o-ring on the adapter when I removed it and this orange gasket was stuck on the block, but not baked on like the larger gasket.

Looking at NAPA's site, if found the following kit. This appears to have the standard two hole gasket, o-ring and orange gasket. Can anyone give any input on this?
 

·
Registered
Joined
·
701 Posts
I cant remember what gasket i used back when i put my new engine in, but im thinking i just used the larger thick gasket on the outer lip of the adaper, and the 2 hole gasket for the top, to help keep the bolts from seeping (maybe the o-ring is for early f-car lt1's, idk). Heres a link that shows a breakdown of the oil cooler and adapter: http://capricess.com/tech/oil_cooler/seo.htm
 

·
Registered
Joined
·
701 Posts
I think i originaly tried putting both on at once, and iirc, the o-ring would squish out from around where the adapter lip met the block when tightened to 17 ft. lb. Btw, i know for a fact that the f car lt1 has a different style oil cooler adapter, and im pretty sure the o-ring is for them, idk.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #6 ·
Well given the fact that I only found the larger gasket when I originally removed the adapter I'm inclined to think you're right. I'll go ahead and omit the o-ring for now and keep an eye on it. Thanks again for your help.
 

·
Registered
Joined
·
76 Posts
I think I got the Fel pro gaskets/rings a few months ago... common problem. I can't remember which ring I used, it came with two...

+ 1 on making sure you get the old gasket paper material off, I was just about to put in the new one in and could of swore there was nothing, the gasket was so flat I thought there was none. Luckily it came off easy.
 

·
Premium Member
Joined
·
41 Posts
I had a oil leak their to took me a while to find it, but when my radiator started to leak behind the oil cooler line up top I noticed that oil was leaking from adapter. when I changed radiator the oil leak was gone.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top