Chevy Impala SS Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
Car was running just fine yesterday. Won't start today. Readily turns over, but won't fire off. If I crank it, it tries to fire just as I let off the key, huffs a few times, but nothing.

I replaced the opti last weekend, but this problem has occurred in the past once or twice. It has always eventually fired up and run just fine. Not today. i checked all connections.

I don't want to drain the battery cranking for no reason.

I have limited tools with me. Suggestions? Coil? ICM?
 

· Registered
Joined
·
101 Posts
Discussion Starter · #3 ·
Oh yeah, plenty of fuel. Sorry, neglected to mention that.
 

· Registered
Joined
·
2,713 Posts
Car was running just fine yesterday. Won't start today. Readily turns over, but won't fire off. If I crank it, it tries to fire just as I let off the key, huffs a few times, but nothing.

I replaced the opti last weekend, but this problem has occurred in the past once or twice. It has always eventually fired up and run just fine. Not today. i checked all connections.

I don't want to drain the battery cranking for no reason.

I have limited tools with me. Suggestions? Coil? ICM?
I have seen this exact thing on another club members car and the two screws that hold the rotor came off.

To the basics, like Greg mentioned, check fuel pump. Is it working? Check fuel pressure at the regulator. Check for spark. Then see where you are at. You say it happened in the past, that really sounds like a fuel pump going bad.
 

· Registered
Joined
·
101 Posts
Discussion Starter · #6 ·
FP is priming when I turn on the key. Popped in an extra FP relay I had, just to check, still the same.

Good spark from the coil and out of plug wires.

SOB acts like it's out of gas, but I know that isn't the case.

Just thinking out loud, do you think the fuel filter could be clogged, causing a fuel starvation? It's getting dark, so I pull it tomorrow to see how stopped up it is.
 

· Registered
Joined
·
2,713 Posts
FP is priming when I turn on the key. Popped in an extra FP relay I had, just to check, still the same.

Good spark from the coil and out of plug wires.

SOB acts like it's out of gas, but I know that isn't the case.

Just thinking out loud, do you think the fuel filter could be clogged, causing a fuel starvation? It's getting dark, so I pull it tomorrow to see how stopped up it is.

Ok that helps out. Filter could be a problem, that is why you should do a fuel pressure check at the regulator.
 

· Registered
Joined
·
101 Posts
Discussion Starter · #8 ·
You're right, but, unfortunately, most of my tools, etc. are about 1700 miles away.......
 

· Registered
Joined
·
214 Posts
If the FP primes and you've checked the coil and it's giving spark, with your symptoms I would definitely do a fuel pressure check. Bet that's your problem
 

· Registered
Joined
·
248 Posts
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top