Chevy Impala SS Forum banner

1 - 5 of 5 Posts
9

·
Guest
Joined
·
0 Posts
Discussion Starter #1
i just put my system in my impala and its just not hitting the base i want give some suggestions
ita pioneer cd head unit
6.5 infinty 605 cs in the front
pioneer 3 way 6x9's and a 12 inch rockford punch z in a q logic box all running off a punch 150 any suggestions its loud as heck but i dont feel the base from the box but i feel off the door speakers
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Your probably not getting enough power to the sub.

Is that a 150x2 amp?
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Let me be sure that I have this correct.
1. You are running the 12 AND the 6x9's off of the 150?
2. Are you using a crossover?

If the answer is yes to the first and no to the second then I think I see your problem. Running a system like that is OK but not desirable. Remove the 6x9's from the amp and run them to deck power or another amp and get a crossover. The 150 should be plenty of power. Also, is the box just sitting in the trunk? If so, you might try different firing positions. Point it back, front and to different sides and see which one sounds better. The best would be to seal it to the rear deck or rear seat but with a 12 you would have a hard time and you would probably have a hard time getting the spare back in.
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #4
If you are running all the speakers off that one amp... don't.

You are most likely running some weird low ohm load which ain't too good for punch amps. I would suggest running only the sub off that amp and all the other speakers off another amp.

What are stats like on that punch z? I bet it could probably take more wattage than what the 150 is giving it. Also Q logic boxes are good for saving space but not the best box for getting loud.

good luck, keep us posted
btw,
I love that camaro!
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #5
thanks for the help
yeah its all off one amp (trying to be cheap)i spend all my money on the camaro so i tried doing this good but cheap ive tried changing locations of the box but that doesnt seem to work ill keep playing with it
thanks 92wagon so do i
 
1 - 5 of 5 Posts
Top