Chevy Impala SS Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
ON A SIDE NOTE;Wassup 2 tha Gang Recently had transmission replaced about a week ago while during so I accidentally broke the sensor on the bottom transmission line with the brass block. Believe its the Transmission Temperature Sensor/Switch. Looking to replace.Where can I purchase them? Also Whats its purpose?

Chevy Caprice 1994 5.7 LT1 "Chanel"

She sat for about 2 months prior before I actually fixed. Now that I have it back running strong seems to be warming up a bit more than usually. Yesterday I noticed I was temperature was about quarter way from the "H" first line after only a 20 minute drive. I bleed air out the system at the T-stat valve, decided I would take still instead of different vehicle to help diagnosis problem. Had to take a Hour trip overheated probably twice before I made it there, would have to exit freeway and bleed & let cool had evened up adding water this time since didn't have much to spend atm. On the way back home she overheated again this time way pass the Hot Red Zone leading up to me just saying f*$k it I work at the shop Ill just rather replace motor if possibly head gasket. No signs of head gasket either potentially yet. Drove it until Check Engine came up, starting sound weird while accelerating to the point pulled over due to loss of power.

I Pulled the Hood and checked oil and everything looked fine, continued to bleed the system once more this time hoping to make it home which was 20 mins away now. Attempted to start sounded like it was cranking weakly but battery was dying. After during this about 5 times battery eventually died. Had to call for ride, decided will come back once everything is cool in the morning.


What is possibly the cause of this? I don't think motor is seized or anything in that nature. I will post update once I'm there & check out wassup with. Just curious to know besides head gasket; What can be the outcome of this worst case Ill just end up replacing engine LT1 5.7 bought the motor used @ 104k 6 years ago. :|
 

·
Registered
Joined
·
1,542 Posts
ON A SIDE NOTE;Wassup 2 tha Gang Recently had transmission replaced about a week ago while during so I accidentally broke the sensor on the bottom transmission line with the brass block. Believe its the Transmission Temperature Sensor/Switch. Looking to replace. Where can I purchase them? Also Whats its purpose?
That sensor is not essential to replace, although it does not hurt to replace it. It's a transmission fluid temp sensor which triggers a command to lock the TCC once the fluid is WAY too freaken hot to make a difference. It may become reprogrammable someday, presently I'm not sure if it is.
Chevy Caprice 1994 5.7 LT1 "Chanel"

She sat for about 2 months prior before I actually fixed. Now that I have it back running strong seems to be warming up a bit more than usually. Yesterday I noticed I was temperature was about quarter way from the "H" first line after only a 20 minute drive. I bleed air out the system at the T-stat valve, decided I would take still instead of different vehicle to help diagnosis problem. Had to take a Hour trip overheated probably twice before I made it there, would have to exit freeway and bleed & let cool had evened up adding water this time since didn't have much to spend atm. On the way back home she overheated again this time way pass the Hot Red Zone leading up to me just saying f*$k it I work at the shop Ill just rather replace motor if possibly head gasket. No signs of head gasket either potentially yet. Drove it until Check Engine came up, starting sound weird while accelerating to the point pulled over due to loss of power.

I Pulled the Hood and checked oil and everything looked fine, continued to bleed the system once more this time hoping to make it home which was 20 mins away now. Attempted to start sounded like it was cranking weakly but battery was dying. After during this about 5 times battery eventually died. Had to call for ride, decided will come back once everything is cool in the morning.

What is possibly the cause of this? I don't think motor is seized or anything in that nature. I will post update once I'm there & check out wassup with. Just curious to know besides head gasket; What can be the outcome of this worst case Ill just end up replacing engine LT1 5.7 bought the motor used @ 104k 6 years ago. :|
My GUESS:
If you do not have any leaks, either external or internal - and you may now have an internal leak aka headgasket leak - my next guess is something wrong with your H2Opump.

Your fan motors may be too weak, your pressure cap may be too weak, your thermostat may be stuck less than fully open …


For anyone else reading this: old LT1 engines are slowly dying off. Please do not let the dash temp needle reach the redzone, much less get into the redzone.
If it touches the white borderline, shut it down before it reaches that little gap.
 

·
Registered
Joined
·
7,957 Posts
Pretty much +1 on Marky- above. TS can be damaged after overheating. Old caps equal higher temps. For the pittance of cost for basically just maint. parts, best to replace them. And a complete flush and new AF so you at least know what you're working with. Also a biggee, the least bit of friction drag on either fan just replace it(them). What did the code(s) read?


On the head gasket, well maybe. But I've run different LTs way overheated in emergencies to the point where it's fubared an old style sbc. I'd be looking a lot of other places first.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
Water pump is fairly new I keep the cooling system maintenance due to it being hot here in PHX. Everything else is in great condition cooling fans, Replaced green Lifetime Radiator hoses with some from Auto zone. I don't think T-stat is the problem because I do get accurate reading on dash, Also can feel coolant flow and both hoses are about the same temperature.


UPDATE: Prior to overheating I checked oil still not signs of a head gasket, I was able to get it started after having to replace bad starter and drove home. Engine sounded pretty weak like lost of power (compression), died at the light few times on the way home. Also has a funny smell under the hood like burnt coolant, while driving it didn't get hot not once like if the temperature sensor on the passenger side block had shorted itself out. Parked it have not drove since


I went outside yesterday to look for any signs of engine damage, just checking the oil I removed the oil cap and filler tube on the (passenger side valve cover), looking down inside where rocker arms are I noticed a loose washer just floating around. I'm pretty sure something internal has broken or became loose. Attempted to started this time and would just crank and die after with "infamous low oil light prompting".


Been thinking I decided to just go head and replace the engine, I have a question regarding. Can I use a engine from a 95' Caprice/SS/Roadmater etc in a 94 Chevy Caprice with the same original PCM and wiring harness? Since the 94 Transmission is only compatible with 1994. I just had transmission installed so kind of curious on what to do. Thanks for Response
 

·
Registered
Joined
·
7,957 Posts
I can sure appreciate the anticipated instant gratification expected from simply replacing the whole motor.... BUT. The resulting letdown will be legendary if that pricey bullet don't hit the mark. And then you'll STILL have to fix the first problem....and with the money you spent on "throwing a big giant part at it". Just saying. More often than I'd like to remember I've found the cause of a new problem turned out directly related to what seemed like COMPLETELY unrelated recent work. Perhaps not the thing you broke with that tranny replacement, but mayhaps something: pinched wire, missed re-connection, something binding. Like, did you mash the steam pipe?
 

·
Registered
Joined
·
8,468 Posts
OP

...so you said F it when the temp gauge was pegged until basically the motor stopped running and on restart it barely would crank, etc, etc.

Not sure why you are asking the obvious but your choice to keep driving very likely killed the motor

That washer laying around under the valve cover....did you even take the VC off and look further?

Whatever engine replacement you get or if you decide to repair the existing motor your wallet will be much thicker if you stop driving any car that pegs the temp sensor (read before it pegs gauge) and find out WTF it is over heating in the first place

Donor motors from 20+ year old cars are not "fresh" motors but would get you back on the road although that cost + whatever cost you dump into a unknown 20 year old used motor to fix issues that become evident after that motor is installed will likely cost as much as a reman motor
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
It was overheating to the point nothing can be the problem unless air in the system which I bleed, removed cap & while running it was back flushing out reservoir. At the time was idea to think head-gasket symptoms.Distributor (Opti )accidentally got wet in the process, seems damage was already done before attempting to get back on road.

Now my question is can a bad water-pump & T-stat still have coolant flow?


l Did driver some core plug (5 months) no leaks has coolant. I keep all parts new water pump, new Distributor, t-stat, hoses, heater core, radiator (no leaks).Not to worried about how much everything on car is warranty outed, expect engine which had for a while if I did swap motor can I used one from a 95 engine. Or is it just possible to swap heads from a donor if not warped.
 

·
Registered
Joined
·
1,542 Posts
If the H2Opump isn't pumping, there's no coolant flow. If the pump seems ok when removed, could be the H2Opump drive mechanism behind the front cover, or the spline key might be worn smooth.
If the thermostat is stuck shut, just replace it.

Except for how they were treated, there are no meaningful differences between a 94, 95, or 96 LT1 Ironhead engine, whether Caprice RoadMaster or Fleetwood.
However, front timing covers & knock sensors can be either OBD1 or OBD2.
So keep your OBD1 front cover & knock sensors to transplant to the newer engine, if you find a 96.

Be careful not to use a 4.3L Caprice L99. Many here will say it's not a bad engine, but I can't say it's a good engine - it lacks the 5.7L LT1's joie de vivre.

If an IronHead LT1 is too hard to find, it's ok to use a Camaro FireBird or 'vette LT1.
Do not use the Camaro's / Firebird's / 'vette's pcm, they won't run sedans' / wagons' AC properly. You'll need to copy several tables from an F- or Y- tune over to your pcm.
Better yet, just get properly reprogrammed by someone like pcmperformance.com, and get some extra power.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #9
Recently drove to shop to do block test for head gasket failure. Fluid Starting to look slightly green then yellowish then tester turned back to blue while testing. Was a confused to see that happen.Currently N the process of saving to buy a 95 LT1 engine from Road-master with 50K miles. Would the wiring harness and 95 LT1 be compatible for 94 Caprice & PCM. Will continue to drive until motor is unable to start and reuse parts. Prior to starts up very weakly (believe loss compression) would have to turn key then rev to get get moving. Have noticed since it died from previous post above coolant temp sensor on passenger side of block stopped working as well doesn’t move from Cold mark.
 

·
Premium Member
Joined
·
951 Posts
Each time you start the engine you are doing more damage to the parts. So your goal of getting a boneyard motor and "reusing parts" is becoming less and less likely with every turn of the key. Yes the harnesses would be compatible between a 94 and 95. This thread is amusing. It's like purposely slamming your finger in a car door and then acting shocked that it's broken, and continuing to try and use it.

I'm not even gonna say "stop starting it" because it won't do any good. The rebuild thread should also prove quite entertaining.
 

·
Registered
Joined
·
7,957 Posts
"......... continuing to try and use it."


The finger? Or the door? ;)
 

·
Registered
Joined
·
25 Posts
Discussion Starter #12
No looking to rebuild motor, also by swapping parts referring to warranty exchange have ltw for most of accessories parts like water pump, distributor and etc so would have new. So shouldn’t be a issue starting motor not reusing internal parts. Checked car-parts.com found a few good LT1s, as well considering buying a Reman.
 

·
Registered
Joined
·
6,786 Posts
Grew weary of replacing "lifetime" parts years ago. I won't put that near worthless crap on my car. I don't care if it is free,my time ain't free...
 
1 - 13 of 13 Posts
Top