Chevy Impala SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1 (Edited)
Here is my wagon. Gave $600 for it several years ago but have never really driven it except to different locations of storage, lol. Its always had some quirks I cant figure out and now it dosent run at all, but I really want to drive it badly. It has a super clean good shape interior with no cracks anywhere. Only problems are faded cloth seats, but not my cloth 3rd row seat, found only on the cloth OCC. The carpet is worn badly on the drivers side also. The engine is really clean too with no leaks on the 176K miles engine or trans.

The problem is that it didnt have a working gas guage when I bought it, it ran great and idled smooth you could just hear the light ticking from the TBI throttle body, or near it. Then one night I cranked it up to just let it idle it just died on me and seems to act like its out of gas. Does this sound like the fuel pump? Brad
http://s3.postimage.org/kFp_9-6c02c4c3c8ea50820a5c604cd38d44fd-resize.jpg

http://s3.postimage.org/kFEY0-6c02c4c3c8ea50820a5c604cd38d44fd-resize.jpg
 

·
Premium Member
Joined
·
570 Posts
Did you forget the pics??
 

·
Registered
Joined
·
986 Posts
When you turn the key to run, can you hear the in tank fuel pump run?
Or the definitive test - Disconnect the fuel line at the fuel filter, aim the line into a bucket and then turn the key to run. You either fill the bucket or you don't and you have your answer on the fuel pump. And now is a good time to change that filter since you've got it half undone already.
 

·
Premium Member
Joined
·
570 Posts
Forgot to add in my previous post:

With the gas gauge not working it might has been running out of gas or on low fuel too often. Fuel pumps don´t like that, since fuel lubricates und cools them.
 

·
Registered
Joined
·
11,239 Posts
The ticking could be the injectors. It would be a good guess about the fuel pump not working. I could be for a number of reasons, but you still have to troubleshoot. Good luck.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
Thanks for the Help! Gonna mess with it soon because my parents are selling their house and it needs to be moved from their driveway, lol. My daily driver silverado is broke down at the moment along with the Mark VIII (its been broke for a while) so I have to fix one of the 3 and I think the wagon will be the cheapest. I just put the driving trans am in the garage for a bucha stuff so it really kills me that the truck breaks down now, hehe. The trans am is getting some drag rear suspension pieces, 200 shot, mega squirt with regular distributor, and a 700r4 with a 3500 stall. I just have to sell my T56 before I can buy the 700r4. I want to go low 11's on stock heads, cam, and short block w/200 shot. I would like the wagon to replace my truck because I really dont haul all that much, just basically stuff that will fit in a large wagon and its got a trailer hitch too :) I also REALLY like the b body alot. Had a previous 9C1 that ran really well. Anyone ever had their whole HVAC display just not light up or work at all?
 

·
Registered
Joined
·
116 Posts
List that T56 in the for sale section here. A lot of guys are looking for them!!!! Good luck on getting it running.
Or better yet put the T56 in the wagon!!!!!!
 

·
Registered
Joined
·
1,149 Posts
Pictures

Where are the pictures that you were going to post?

Tom C.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #9 (Edited)
1 - 10 of 10 Posts
Top