Chevy Impala SS Forum banner

1 - 4 of 4 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Oh man. I just finished up everything but the power cable on the battery. I tried for half an hour to get the hookup. BTW, i have a DieHard Gold battery which I bought about a month ago after my last battery bit the dust. It only has normal terminals, no posts. I also bought a StreetWires screw-in post for the positive terminal, but it won't fit in the stock rubber boot (it's a little big)!!!! :mad: Would it be safe to take the boot off entirely and use my new post or just bring the damn car to Circuit City or Car Toys to get it hooked up? My car MUST be 100% put back together by wednesday night so i can sanely make a 4 hour trip back home. Please, oh please, somebody help me
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Just "Trim" a Little Bit Out Of The Red Rubber Around The Positive Battery Cable Post Hole. Use a Razor Knife Or Even Some Sissors But I Wouldn't Remove The Red Boot! You CAN Do This! It's Very Easy! Is The Bolt Your Trying To Use Longer Than The Stock One With a Nut On The End To Mount The Amp Wire To The Battery? If So, You Have The Correct Bolt!.....Mike
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #3
If you cut off the boot than replace it with some electrical tape.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Hey, B-Body. Thanks. It was the right bolt (post to connect connector to and all). A warm engine with more flexible rubber boot helps. That and putting the bolt in from the OUTSIDE of the boot
:D
 
1 - 4 of 4 Posts
Top