Chevy Impala SS Forum banner

1 - 8 of 8 Posts
N

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi Everyone,


I have a question about the rear view mirror on my 1995 Fleetwood. The mirror is loose and it vibrates like crazy. I can not see anything out of it because of all the shaking.


I was moving it around to try and see where vibration was coming from. Well it came off in my hand. It slid off the mount on the windshield and that is where I found the problem.


It does not lock on to the mount with a set screw like every other rear view I have seen. This has a flexible metal bracket that slides into grooves on the windshield mount. This bracket is where the vibration is coming from.


He is my question. Does anyone know if that metal bracket can be replace or does the entire mirror need to be replaced? Thanks very much for your help. Any information will be greatly appreciated. Have a great night.


Respectfully,


GeoGoGOo
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Unless you have reason to think it's actually broken, just reinstall it til it clicks in place. There's 2 detents, the first is easy, but it's a real tight fit to seat it home by eyeball and feel. And, if you come away with the glued mount pulling off the windshield, just reglue it. The adhesive gets old after a dozen years. Otherwise, hit a junkyard or Google (or even Dal).
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #5
GO TO A WINDOW SHOP THEYLL FIX IT FOR LIKE 12
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #6
You know...from the time I bought my '95 back in January '06, over time, there seemed to be more and more of a slight vibration of the mirror that drove me nuts going down the road. Not enough that you could pull on it and it even feel loose, but SOMETHING. Got worse with heat, and one summer day just fell off the windshield.

After a cleaning and re-glue, all was rock steady--so it must have just been a partial weakening of the glue in spots that caused it.

Then again, now it's been cold for a while, and I'm starting to notice a hint of vibration in it again going down the road, so maybe the glue is once again getting weak. We'll see.
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #7
I had the same problem with my fleetwood and couldn't find the screw either. Went to the dealer for an oil change and they clipped it in like described in the form.

The problem then occurred in my DTS and I tried the same thing but bent the clips to make them tight again.

Problem solved on both cars.
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Thanks everyone for all the information and ideas. I will check it out this weekend after the storm. Have a great night!
 
1 - 8 of 8 Posts
Top