Chevy Impala SS Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
1,025 Posts
Discussion Starter #1
So i reran my system today. I upgrade my ground wire to 0 gauge from 4 gauge and mounted it to the rear seat belt bolt. Now all of a sudden my Mono amp is getting horribly hot an shut off mins after song plays. I never had this problem until I hooked the 0 gauge ground up!
 

·
Registered
Joined
·
6,746 Posts
Grounding woes

So,what's grounding your body? If it's the little wire going to the fender from the battery,you're asking for trouble big-time. Much of the wiring harness depends on a grounded body,and now you're pumping power into it. You could catch something on fire doing stuff like this. Ground the body to the motor pronto.
 

·
Premium Member
Joined
·
8,383 Posts
So should I go back to the 4 gauge ground wire since I'm running 4 gauge power wire? I read on the audio forums that the power and ground should match.

Sent from AutoGuide.com Free App
As 1slow96 stated make sure your body has a good ground as well, but place for high power amplifier grounds are on the frame itself.

Now as far as putting 4G back on for ground. NO. What you read on audio forums is correct but misconstrued. IF you have a 4 G power you need to have a 4G or LARGER ground wire to match.

Where was it grounded before that it wasn't causing the amp to heat up?

My suggestion, for 0G ground wire, drill hole in body in a place you can run wire direct to the frame, burnish or sand frame to clean shiny metal, attach ground lead.

Pretty good video here to give you the basics.

Definitely make sure that your body ground located on the right fender next to the battery is good an tight and not corroded, it is good to check that as well.
 

·
Registered
Joined
·
6,746 Posts
Grounding woes

Absolutely wrong. The only reason to run ground cable the entire length of the car is failure to ground the body,frame,and motor to each other properly.
 

·
Registered
Joined
·
6,746 Posts
Grounding woes

I have quite a few grounding cables/straps. Most are one foot,or shorter in length. Motor/body, motor/frame, body/frame,etc,etc...
 

·
Registered
Joined
·
6,746 Posts
Grounding woes

No,my battery's in the trunk. There is a 2/0ga. power cable to the starter,and a 2ga. power cable to the aux. post. Battery is grounded to the body/frame with a 2/0ga. cable,and a 2ga. ground to body itself.
 

·
Registered
Joined
·
6,746 Posts
Grounding woes

May reduce your amp system symptoms,but you have grounding issues that are not going away by themselves. I would address them,pronto.
 

·
Registered
Joined
·
1,025 Posts
Discussion Starter #16
May reduce your amp system symptoms,but you have grounding issues that are not going away by themselves. I would address them,pronto.
Ok so ill do this double check my amp ground. Run a 4awg ground from battery to chassis... chassis to engine... 4awg power wire from battery to alt... run 4awg power wire from battery to aux. How do this sound?

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
6,746 Posts
Grounding woes

Seems reasonable,probably better than what you have. I prefer heavier gauge.
 

·
Registered
Joined
·
3,004 Posts

·
Registered
Joined
·
6,746 Posts
Grounding woes

Gary makes good stuff,but anyone can learn to make their own. There is nothing magical about it. I get my cable/supplies from http://delcity.net
 
1 - 20 of 30 Posts
Top