Chevy Impala SS Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I am new to the Forum and new to my very used Impala SS. First of I would like to say hello to all on the forum. I have a 96 SS 5.7 and need some help and advice. I got the my car a month ago knowing it was in need of some much needed TLC but I have a skip that I cannot seem to get rid of. I have replaced the following things thinking I might get rid of the skip. I scanned the car and got a random missfire code "cannot remember the number tho". I replaced the opti,cap and rotor,wires,plugs,Ignition module,Fuel pump,fuel filter. I am at a lost and don't know where to go next. I love the car and want it fixed so I can do the things that most people do to these cars. It has 180k but I have the time to fix it and want to do exactly that. Thanks in advance, John
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
I will try that next week. How about the EGR valve? I forgot to mention that it seems to run ok when I rev it up. When I scanned the computer it only showed a random missfire and a trans code. AGAIN thanks for all the help.
 

·
Registered
Joined
·
731 Posts
To test the egr valve, remove the vacuum hose from the egr valve, and depress the diaphram and put your finger over the vacuum port. If it dont hold vacuum, its bad. Also, its possible for the egr to get carboned up so bad that the pintle wont seat good enough to seal. The egr valve has to be removed to clean the crud from the pintle/seat. If you need a new egr, source one from an M6 lt1 f-body, they have a better spring and diaphram than the b-body lt1 egr valve.
 

·
Premium Member
Joined
·
6,358 Posts
make sure opti vacuum harness is working, if you replaced it make sure it is hooked up the correct way.
 

·
Registered
Joined
·
932 Posts
Did you put on another coil?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
Did you put on another coil?
No, I started a list of what I wanted to replace and shocking to myself I didnt put a coil on the list. Mr pogo, I just hooked the vac hoses back up the way they came off. One more thing that I didnt mention is that the car runs rich also. Man I cant wait to get this thing to run good so I can move on to the appearence.
 

·
Registered
Joined
·
5,693 Posts
Front O2's might be in order, clould have a broken injector wire , but I don;t think that woukld set the mis-fire code, it would just miss.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #9 ·
A clogged injector has crossed my mind. I think tommorow a coil and front o2s will be the next thing to be replaced. If anybody thinks of anything else I would love to know. Thanks so far guys. Maybe this will be the week it will run right and then I can start worrying about the trans and getting it re-geared.
 

·
Registered
Joined
·
639 Posts
I scanned the car and got a random missfire code "cannot remember the number tho".
While the previous suggestions may cure the problem, alleviate the guessing and get it scanned. Tell us what code it is and that will be the least frustrating/expensive route.cwm1
 

·
Registered
Joined
·
796 Posts
Can pick up a cheap scan tool for around $30.00 at most auto stores, you will use it ALOT so go get one. Do youself a favor and get a set of FSM off E-Bay, you can pick them up for around $50.00 for the pair(usually) They will be your best friend when(not if) things need attention. My 96 SS also has over 180K miles and with general maint. and some luck it it still holding up good. I can honestly say I still love the car, and it is a great looking body style(to me anyway). Congrats on the car and welcome to the Forum - Lance
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #12 · (Edited)
I replaced the front o2s and the coil but the miss is still there. The only thing showing when I scan it is a trans code. The first time I scanned the car it show a multiple cyl missfire and the trans code. The good thing about all these parts that I am getting is that its not hurting to replace the cheaper parts. I was wondering about it having a bad injector but I wanted to ask before I put that much money in it unlike the other things that I have replaced. Does anybody offer an aftermarket performance injector that isnt ungodly expensive? My future plans for the car is to have a good strong car that I wouldnt have to put things like turbos or a supercharger altho it would be nice. I have read the go fast basics for a b-body and would like to do something like the 227 cam and do some head work and so on.But I have to get it to run right first. Sorry for the long post and I want to thank everybody for there input. I retired last year from Advance Auto Parts and miss working there so much so it dont bother me to drive to the store that is right down the road to borrow there code scanner lol. Thanks again JOHN.....
 

·
Registered
Joined
·
1,361 Posts
Check your EMI fuse in the fuse box. I'm thinking something might have touched exhaust on the drivers side. Does it feel like you don't have gears?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #14 ·
My trans wont change gears by its self. I unpluggd each injector today and cyl number 7 didnt change the idle at all so I figure that I need to replace that injector.
 

·
Registered
Joined
·
1,361 Posts
Did you check the fuse. The shift b solenoid being bad will do this also. I had my brand new trans do this to me-Damn electronic part failure. What is the trans code you are getting?
Can you manually shift the trans into first and second? The part is 18 bucks and some change but you do have to drop the pan to the trans.

Here is what my car was doing,it sounds very close to what you are dealing with.

http://www.impalassforum.com/vBulletin/showthread.php?t=233370
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #16 ·
Did you check the fuse. The shift b solenoid being bad will do this also. I had my brand new trans do this to me-Damn electronic part failure. What is the trans code you are getting?
Can you manually shift the trans into first and second? The part is 18 bucks and some change but you do have to drop the pan to the trans.

Here is what my car was doing,it sounds very close to what you are dealing with.

I just walked outside and checked every fuse in the car and all of the fuses were ok. I can manually shift and I have no slipping or anything like that. I cant remember exactly what the code was but I will go check it tommorow and let you know.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #17 ·
I hate to dig up an old thread but I still am having problems with the miss my car is having. I completly replaced the fuel rail off a good running 96 Z28 and the problem still exist. I dont remember if I mentioned this but the car seems to run ok whn I rev it up or it seems to anyway. Does anybody think I might have a bad lifter or something in that area? I have replaced everything and am running out of options.Thanks again guys.
 

·
Registered
Joined
·
930 Posts
I did not see if you replaced your plug's and plug wires and coil wire and maybe look into a opti too? does your EGR work? mine was failing and causing a stumble just one more thing to look at, opti vent harness?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #19 ·
I did not see if you replaced your plug's and plug wires and coil wire and maybe look into a opti too? does your EGR work? mine was failing and causing a stumble just one more thing to look at, opti vent harness?
I have replaced it all. I have another egr out in the gararge I will try and see if it makes a difference. That would be the only thing that I havent replaced.
 

·
Registered
1996 BBB
Joined
·
2,576 Posts
Noid lights are your friends. GM cars have a terrible track record for injector wiring going south. Test all while wiggling, gently tugging on the harness. Also, take a pick and pinch all the connectors closed at the end of the injector harness so they grip the nodes on the injector tightly.

If the problem ISN'T intermittent, you may want to do a compression test on each cyl, check each plug for oil deposits ect... Could be a bummed cyl or as simple as a weak valve spring or loose rocker arm.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top