Chevy Impala SS Forum banner
1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
I noticed that my front suspension was acting too soft, and didn't know why. So last night went for a ride with the windows down and noticed a weird rattle coming from the front passenger side. Crawled under the car and found one of the end links on the sway bar was loose so I snugged it up. I could bounce the car up and down by hand and still heard a metel on metal clunk.

Bottom line is I found the top part of the shock had snapped off, right where the threads start. I know it was not over tightened, and I didn't hit any curbs. Anyone else ever hear of a shock failing in this way???? By the way my car is not lowered. I thought Bilstein shocks would hold up a little better, they have only been on the car for 10 months. The shocks do have a lifetime warranty, but talked to the warranty dept at Bilstein and they would not say if it is covered under warranty, they have to see the part first. :confused:

Hope I get a refund for the failed shock. I am sending all the requested info to Bilstein, and hope for thr best.
 
G

·
Discussion Starter · #2 ·
If they are not to old there should be no problem with swapping only one. But, if they have some miles on them you may not want to replace just one. This is something I would ask Bilstein about when you call them.
JP
 
G

·
Discussion Starter · #3 ·
Not too worried about that, only 5,000 miles. I may just get a set of Monroes to put on.

Were you at Autofest last year??? I was, had a good time.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top