Chevy Impala SS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
So I'm trying to switch out my water pump and I go to remove the smog bracket. Everything I've read and seen has shown two bolts for this but on mine there looks to be a third one behind the spark cables. Am I seeing this right? I took the two bolts off and the bracket is very tight. :confused:

Part no. on the bracket: 10215680A
 

Attachments

·
Registered
Joined
·
7,986 Posts
You must be missing a bolt. IIRC and its been a while, just remove the bolts and it pretty much fell off the engine block. I have mine at home that I can take a closer look at later if you need it.

Did you look at the "remove your airpump" thread or even just take a look at another bracket? That should pretty quickly show you where the missing bolt is. Here is a pic of all the parts with the bracket and may help you find the missing bolt.

http://www.impalassforum.com/vBulletin/showpost.php?p=2196799&postcount=29
 

·
Super Moderator
Joined
·
3,881 Posts
Theres a bolt holding the AIR pipe to the back of the bracket . You can just see the tab coming off the pipe where the spark plug holder is. Takes a 10mm wrench por socket. There is also another bolt down behind the spark plug wires by the OPTI.

Remove those two and the bracket will pull right off.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
Thanks all. We figured it out earlier. There's nothing in the Haynes manual or videos I watched about those additional bolts. Luckily my friend was able to get that back Opti bracket off. I could not fit my hands back there. Mission accomplished. :)
 
1 - 4 of 4 Posts
Top