Chevy Impala SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7,982 Posts
Discussion Starter #1
Any members in the Sneads Sferry/Topsail Island area of North Carolina able to help? We got here in my 95 Caprice but about half of that drive down with the fam I was biting my fingernails. Car was missing a little and progressively got worse to the point I had to power brake at lights just to keep it running. Made a stop at the border for Cracker Barrel breakfast and the car would not start but had fuel. Finally got it to fire and limped all the way here. At one pint it started and seemed to run good about 15 min from our destination but quickly started again acting funny. Pulled into our spot for the week, parked it and kissed the ground we made it all the way.

Now though it is dead as it just cranks and won't fire. I strongly suspect a bad ICM again and left my spare about 500 miles back home. On a strong hunch, I ordered a ICM from advance and will be here Monday at noon. I'd love to have a coil/icm piece I could bolt on just to confirm it. So if you have something and are close to the area, please let me know. I have some tools I brought but not a lot of tools either. May be able to borrow some from advance though. I really hope it's the ICM but these things are expensive.
 

·
Registered
Joined
·
1,474 Posts
Any members in the Sneads Ferry/Topsail Island area of North Carolina able to help? We got here in my 95 Caprice but about half of that drive down with the fam I was biting my fingernails. Car was missing a little and progressively got worse to the point I had to power brake at lights just to keep it running. Made a stop at the border for Cracker Barrel breakfast and the car would not start but had fuel. Finally got it to fire and limped all the way here. At one pint it started and seemed to run good about 15 min from our destination but quickly started again acting funny. Pulled into our spot for the week, parked it and kissed the ground we made it all the way.

Now though it is dead as it just cranks and won't fire. I strongly suspect a bad ICM again and left my spare about 500 miles back home. On a strong hunch, I ordered a ICM from advance and will be here Monday at noon. I'd love to have a coil/icm piece I could bolt on just to confirm it. So if you have something and are close to the area, please let me know. I have some tools I brought but not a lot of tools either. May be able to borrow some from advance though. I really hope it's the ICM but these things are expensive.
I'd be willing to bet someone can prove you've overpaid for the driver module, but that premium may be worth it to you in this case.
ANYWAY
IFF you assume it's an ignition problem, could also be the coil, coilwire, Opti-snorkel, the wiring harness that the Opti gets connected to …
If it turns out it's the coil driver, don't forget to use the correct heat sink paste.

There are other possibilities, but they don't come to mind rapidly …
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #3
I'd be willing to bet someone can prove you've overpaid for the driver module, but that premium may be worth it to you in this case.
ANYWAY
IFF you assume it's an ignition problem, could also be the coil, coilwire, Opti-snorkel, the wiring harness that the Opti gets connected to …
If it turns out it's the coil driver, don't forget to use the correct heat sink paste.

There are other possibilities, but they don't come to mind rapidly …
Anything is worth it at this point....We need to get home Friday. 0:) I have valid reasons for leaning toward the ICM (see my recent "Can coil kill the ICM) at this point and pretty easy to swap. Worst part is the Car is right in the Hot Sun but will know later today once I get the part. If it doesn't fire, I'll be looking for a shop in the area. So later today it will be, install Key, say a little "Please Start", turn the key and hope she fires.
 

·
Premium Member
Joined
·
1,514 Posts
Anything is worth it at this point....We need to get home Friday. 0:) I have valid reasons for leaning toward the ICM (see my recent "Can coil kill the ICM) at this point and pretty easy to swap. Worst part is the Car is right in the Hot Sun but will know later today once I get the part. If it doesn't fire, I'll be looking for a shop in the area. So later today it will be, install Key, say a little "Please Start", turn the key and hope she fires.
May the Force be with you. :smile2:

Mark: Snowman-33
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #5
Thanks but it looks like I have more of the Dark Side in my future. Icm did not fix and waiting for the Tow Truck driver to call me. This sux, but be dammed if this will ruin my vacation.
 

·
Registered
Joined
·
7,865 Posts
Apologies if it is in fact you who was recently hunting down hard/no start issues before, but someone smart here recently recommended looking the EGR with generally the symptoms you have. You gots the right tack though, this too shall pass and fambly will forever remember how it did NOT rob points from your vaca.
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #7
I did have a defective EGR about a month ago that was causing the to buck under light load while cruising.

I was on the right track with guessing "No Spark" Turns out this issue while here on Vaca is my Opti. :frown2::frown2: The Repair shop down here is Rick's Auto and he really sounds like a good guy as there is still something that he's not happy about. He used a Duralast and those things dont have good reviews at all. But may be what I need to get home and deal with later. Still no idea what this is going to Co$t me. It will be another long drive of dreading every little hiccup until I finally pull into my driveway.
 

·
Registered
Joined
·
7,865 Posts
So, that WAS you. ;)

Whatever gets installed, and if he's really a square gent, then be sure either he (or lets you) blueprint the new whatever brand to head off the 8 most common failure modes eh. FWIW, the previous owner of my 52k FWB showed me the receipt for $1,100 for a 'genuine dealer' opti he had gotten installed - that turned out to be merely one of the usual sketchy suspects (Spectra? A1? IDR). You can take solace in knowing you probably won't get taken for quite as much. Hey I'm just here to help.

Seriously, best luck.
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #9
Well, this was a real Cluster Fu(% that no one could figure out. The Shop there couldn't really figure out the issue and I'm just very discouraged right now and will look into this later. He installed a new Opti which got the car started but the Fuel Pressure kept dropping off for some reason. A new Pump and SU and still no change but I at least have fuel pressure now.

Car is home and in the Garage at least but this was my Expensive Ride home and nearly 500 mile Drive. This really sux but in the end, there is always a solution as long as you can spend money which I don't really have. But I try to remain Positive and lucky we at least made our destination and didn't get stuck on Rt. 95 in the early morning.
 

Attachments

·
Premium Member
Joined
·
1,514 Posts
Well, this was a real Cluster Fu(% that no one could figure out. The Shop there couldn't really figure out the issue and I'm just very discouraged right now and will look into this later. He installed a new Opti which got the car started but the Fuel Pressure kept dropping off for some reason. A new Pump and SU and still no change but I at least have fuel pressure now.

Car is home and in the Garage at least but this was my Expensive Ride home and nearly 500 mile Drive. This really sux but in the end, there is always a solution as long as you can spend money which I don't really have. But I try to remain Positive and lucky we at least made our destination and didn't get stuck on Rt. 95 in the early morning.

Just drafting that UHaul or avoiding bug splats? Glad you made it back home. Now down to the diagnostics.

Mark: Snowman-33
 
1 - 10 of 10 Posts
Top