Chevy Impala SS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 · (Edited)
SQUEAKING NOICE from engine dont know where is coming from HELP

Ok so I just put the lt4 kit in my 96 impala, and after start up and driving only like about 50 miles a annoying squeak started. About 4 or 5 months ago, I bought a chrome 100 amp. alternator for my car audio set up and so same time I bought a new belt. SO after the lt4 kit, bought belt condtioner and nothing, bought a GAINES brand belt and the noise went away for maybe 40 more miles, and now its back. Also I just replaced my harmonic balancer with a Auto Zone OEM harmonic balancer. The squeak is driving me NUTS PLEASE HELP.
 

·
Registered
Joined
·
885 Posts
I my case on my build I had a similar noise, turned out it was the teflon rear main seal making it. I should have put a standard one instead.

I also had a 2hg vacuum crankcase setup that I removed for a standard pcv and it cured my teflon seal noise.

Run without the belt to make sure the noise is from the engine not accessories.

Before finding that I tried two different belts, and when changing it the first time I noticed I could actually make the idler pulley squeak when moving it up down with the ratchet. Opened it and greased everything up and this noise was cured but the not engine noise. Also tried 2 alternators thinking theirs bearing noise would be the culprit but no, even if by hand I could reproduce a noise, it was silent when on the engine with a belt.
 

·
Registered
Joined
·
932 Posts
Check your belt tensioner and pulley. The tenssioner spring gets weak. Sometimes the pulley bearing fails.

I had an annoying squeek at idle. It turned out to be the BELT. Replaced with a Goodyear Gatorback belt and presto, it disappeared.
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #5 ·
Check your belt tensioner and pulley. The tenssioner spring gets weak. Sometimes the pulley bearing fails.

I had an annoying squeek at idle. It turned out to be the BELT. Replaced with a Goodyear Gatorback belt and presto, it disappeared.
At first my squeek was only during driving, at idle no squeak and now soon as the car engine turns over it squeaks.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top