Chevy Impala SS Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
My brakes squeek pretty bad up front. I just put them on, new pads/rotors about 5k miles ago. I did get some wd-40 on them because i used to spray my wheels with it before i had hubcaps. I took the wheels off and sprayed brake cleaner on the brakes. Still squeeks. It's embarrasing and everyone tells me "you need new brakes" but I just did them and they work fine!
 
G

·
Discussion Starter · #2 ·
What kind/brand of front pads and hardware(calipers, rotors) do you have?

Also what are the rear drums, and hardware looking like, old, new(er)?

Also write down the exact problems of the car and we can most likely look at it at the meet.
 
G

·
Discussion Starter · #3 ·
Just the front brakes. I guess Duralast because they are from Autozone. never checked the rears. Fronts squeek with light pressure comming to a stop. If I apply more pressure the squeek stops.

Car hit 180k today btw.
 
G

·
Discussion Starter · #4 ·
How about the rotors, what is their condition like?

May I suggest a set of performance friction pads($30) and a set of new rotors.
 
G

·
Discussion Starter · #5 ·
Did you bend the ears on the outter pad so they sit TIGHT againist the caliper? Just take the pad of and wack the ears with a big hammer. 1 light hit should do it.

You know the pad is loose in the caliper right away when you take off the wheel and wiggle the rotor back and fourth and you see the pad wiggling around. Well atleast in my case.

I had the same prob a few weeks ago. Light braking, alot of noise, hard braking, quiet. My brakes where silent for some time also.

While I was at it, I lightly sanded the rotor and pad, also greased the bushings in the caliper and cleaned up the pin to insure free movement.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top