Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
so i posted on here b4 and did a lot of different things to figure out this miss but it is still there. so again im looking for any input its a 96 impala.

u can only feel the miss when you are at cruising speed and the ac is on. it has nothing to do with the ac only the fact that it draws more power from the motor. and it is a very very very slight miss almost unnoticiable but its there and its anoying also it is a intermediate miss.

things ive done so far is new plugs, new wires, fuel preasure check, sent the computer out and had it reflashed with all gm updates installed. i have not messed with the opti yet cause that is a lot of money and ive checked all vacume hoses and everything seems fine

any points in the right direction would be helpfull. i just put some lucas inj cleaner in the tank so we wil lsee wher that gets me
 

·
Registered
Joined
·
3,612 Posts
How many miles on this car? I can tell you that I replaced the cap & rotor on my Opti on my 9C1 at about 140,000, and it made a noticable difference in engine smoothness.

Before tackling the Opti, though, make sure all plug wires are secure. Also, clean your MAF, IAC and throttle body.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
car has 116k on it, ive also already cleaned the maf and throtle body. the maf is not a oe one, it is a aftermarket brand, not aftermarket like auto zone but a performance aftermarket one. also i would like to add that there is no check engine light on. what bugs me the most is i dont think there is any real mechanics left, when i bring it to a shop they all say it wires, they dont even want to test drive it or anything, i think they are all just parts changers.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #5 ·
its a granatelli motor sports MAF and also the car has a raiss intake. the ecu is flashed back to stock no programs are installed
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #6 ·
can i disconect eh maf and drive the car see what happens? i know the cel will come on but will the car still run right with it disconected
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #7 ·
well i disconected the maf and it still seems like it has the same miss, its really hard to tell cause the miss is so slight and intermediate.
 
1 - 7 of 7 Posts
Top