Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
I just installed a Yank SS3600 TC this afternoon. I drove after install with no issues until I got home and backed into my garage. When I drove in reverse it felt sluggish and made a faint squeaky noise. The noise would not continue the whole time I would reverse but just initially. It felt like the emergency brake was on but I checked and it wasn't. Any ideas? Let me know if more information is required.
 

·
Registered
Joined
·
214 Posts
Thats how my car feels with the 3200 stall and 22" inch wheels. Before with a 2800 stall and 20's the car felt a whole lot better, but expect the car to feel sluggish with a high stall. Especially with a 3600, you will feel like if the e brake was on. Gears would fix that.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
Thats how my car feels with the 3200 stall and 22" inch wheels. Before with a 2800 stall and 20's the car felt a whole lot better, but expect the car to feel sluggish with a high stall. Especially with a 3600, you will feel like if the e brake was on. Gears would fix that.
I do have 3.73 gears installed. I'm going to have my mechanic take a look and make sure everything is okay.
 

·
Registered
Joined
·
2,027 Posts
I think it's because reverse has a higher gear ratio so it takes more rpm with the high stall to get it going, thats why it feels sluggish.
 

·
Premium Member
Joined
·
3,564 Posts
I'll let you back up with the SS4000 Yank! The SS3600 should be pretty tight though.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #6 ·
Thanks for all the replys. I found out that the squeaky noise was my driver side front brake which I guess I never noticed before which is odd. I am getting use to the Yank SS3600 and I am liking it.
 

·
Registered
Joined
·
3,841 Posts
I love reverse with my 3600! Reminds me im modded! Wait until you reverse going up an incline lol.
 
1 - 7 of 7 Posts
Top