Chevy Impala SS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
Hi Guys,
posting this here because I am thinking it could actually be related to a high idle and not a transmission/driveline issue. My car has a high idle and will run along at 20 mph easily with my foot completely off the gas. When I am coming to a stop it downshifts hard from 2-1 and I feel a clunk right before stopping. Is this due to the high/erratic idle? I just replaced the TPS and unfortunately that did not fix my issue. I checked the vacuum lines and all seem fine. None are dried out or broken. My next step is to replace all plugs and wires clean the TB and the IAC. Any other suggestions? Think if I fix my idle I will fix my clunk?
Thanks
 

·
Banned
Joined
·
3,437 Posts
the idle is 650 rpm in gear stopped or in neutral in park. if the idle is above this you will get your issues. check for vacuum leaks . the PCV and the hoses are big items then the vapor fuel purge hoses on the passenger side of the intake manifold.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #3 ·
the idle is 650 rpm in gear stopped or in neutral in park. if the idle is above this you will get your issues. check for vacuum leaks . the PCV and the hoses are big items then the vapor fuel purge hoses on the passenger side of the intake manifold.
yup, I am thinking it must be that too. I took a quick look but didnt notice anything bad. Will need to inspect much closer. I will report back.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top