Chevy Impala SS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Here's the situation (1995 caprice wagon)

I have a slow transmission fluid weep from between the male threaded fitting and cooler line from the rad on the lower drivers side of the rad. I had a leak in the hose at the cooler line (same line), rubber hose transition and during the fix may have loosened the connection into the rad. Any thoughts, planning on (i) loosening and re-tightening the fitting into the rad (ii) repacking with teflon tape and if necessary (iii) changing the line. Any ideas?

Cheers
Sean
 

·
Registered
Joined
·
2,703 Posts
You hope it is there. Try that fix, it may work. Use a double wrench system with a flare wrench. Do not overtighten. But often it is the plastic tank that has a crack at the fitting. Then you get to try JB Weld or all manner of fixit type products but usually requires a new radiator which may not be a bad idea if it is original or high miles. Good luck.
 

·
Registered
Joined
·
1,265 Posts
You hope it is there. Try that fix, it may work. Use a double wrench system with a flare wrench. Do not overtighten. But often it is the plastic tank that has a crack at the fitting. Then you get to try JB Weld or all manner of fixit type products but usually requires a new radiator which may not be a bad idea if it is original or high miles. Good luck.
If there is a crack in the end tank, replace the radiator, do not waste your time playing with epoxies.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top