Chevy Impala SS Forum banner

1 - 6 of 6 Posts

·
Premium Member
1996 Caprice 9c1, 2018 Ram Laramie CC 4x4 EcoDiesel , '03 Ram 3500 Laramie Sport QC 4x4 Cummins
Joined
·
635 Posts
Discussion Starter · #1 ·
My car has been sitting for a couple months while I took my time installing a Z28 cluster and adding some sound matting. I took the car on a test drive to see if the Z cluster is where I wanted it. I noticed that I had a check engine light on,got home and pulled a P1661 code. I believe its a MIL Control Circuit according to my cheap ass code reader. Since I loaned out my FSM to a friend who is out Moose hunting,I'm unable to do any reading up on the subject. I also think my trans is shifting a tad funky,harder then usual and it also downshifts into first by its self around 2 or 3 mph. I'm wondering if the code is causing the trans to act up or I have 2 different issues. The only mods I've done with the car is a cold air intake,air pump disabled and a custom tune by Brian.

What say you?
 

·
Registered
Joined
·
3,612 Posts
You are correct about the code. Does the CEL come on when you turn on the key? If not, check the bulb and your wiring. I believe this code will cause the PCM to operate in 'open loop' mode full time, which is probably why your transmission is operating funny.
 

·
Premium Member
1996 Caprice 9c1, 2018 Ram Laramie CC 4x4 EcoDiesel , '03 Ram 3500 Laramie Sport QC 4x4 Cummins
Joined
·
635 Posts
Discussion Starter · #3 ·
Oh ya the light comes on with the key. I went ahead and reset the code to see if it gets tripped again. Whats weird is the car had no problems when I parked it,and now after the Z28 install,I got the check engine light.
 

·
Premium Member
1996 Caprice 9c1, 2018 Ram Laramie CC 4x4 EcoDiesel , '03 Ram 3500 Laramie Sport QC 4x4 Cummins
Joined
·
635 Posts
Discussion Starter · #4 ·
Anybody have a clue where to start looking? I started the car after resetting the code and it comes back. I haven't noticed any lose of power and seems to run just fine.
 

·
Registered
Joined
·
1,040 Posts
was the harness for the cluster made right? may have a problem with the cluster, considering it happened after the fact
 

·
Premium Member
1996 Caprice 9c1, 2018 Ram Laramie CC 4x4 EcoDiesel , '03 Ram 3500 Laramie Sport QC 4x4 Cummins
Joined
·
635 Posts
Discussion Starter · #6 ·
As far as I know it was made correctly. The cluster was purchased from a forum member and he does sell a bunch. All gauges and lights work.
 
1 - 6 of 6 Posts
Top