Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,694 Posts
Discussion Starter #1
Where is the Twilight Sentinel box on a Fleetwood? Not on the passenger side kick panel like a Buick LT1 car. Did they leave it over the steering column like a TBI car? The FSM doesn't show where it is either that I could find...

I'm having an issue where the low beams don't work for the first 30 minutes of driving. After 30 min I switch back from Hi's and they work....

I changed the hi/low switch on the column TWICE. It now has a new Delco unit that worked for about a month before reverting to no lo beams. I can't imagine two new switches in a row are bad...

the TS seems to work okay as the marker lights go on/off, however, they seem to turn on when it's still pretty bright out. Someone suggested that it might be the module and I have a spare to try.
 

·
Premium Member
Joined
·
860 Posts
No one knows...

My guess is no one actually knows the secret of the Twilight Sentinel operation on a Fleetwood. I could never find it and replaced several dash modules before giving up when I figured out "maybe" the '96 FLT came with DRL function...except for the lights being out in daylight. They would come on automatically in darkened conditions but could NOT be manually turned off.

I believe the "94 FLT has full manual control override, but don't have it handy to check.

The fact that yours has restrictived operation leads one to consider there is a fault somewhere else along the circuit. The FSM is not a lot of help in this one area. Have you asked on the Cadillac forums?

Please share what you find here for the one or two people who still read this forum.

Richard Snipes
4501 Safari in Jax, FL
 

·
Registered
Joined
·
3,694 Posts
Discussion Starter #3
Well for about a week the low beams would come on after about 30 min of driving If I would flip back to them. That has now stopped as well.

I was told that the TS circuitry runs through the CCM!? The FSM also points me to the CCM for diagnostics to the Twilight operation...

I am getting a CCM out of a 96 FW that Eagle CO is parting out, so I will swap and see what happens then. After that I guess I'm in the wiring with multi meter trying to figure it out.

It may be that the switch went bad, but if that IS the case, then why I have I burned through three switches in a year....stay tuned.
 
1 - 5 of 5 Posts
Top