Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
551 Posts
Discussion Starter · #1 ·
Noticed this tonight at the strip.

WOT sift 1st to 2nd is fine, but 2nd to 3rd no go unless I back off the throttle slightly.

Driving regularly seems to shift fine, even under a moderate acceleration.

Any ideas ?
 

·
Premium Member
Joined
·
20,353 Posts
3/4 clutch pack is giving out.

When the tranny takes a complete dump depends on how hard you push it.....but you WILL need a rebuild......soon.

You can drive the car gently for awhile.....but it will never be a decent racer with that tranny in it's current state.

KW
 

·
Registered
Joined
·
551 Posts
Discussion Starter · #3 · (Edited)
3/4 clutch pack is giving out.

When the tranny takes a complete dump depends on how hard you push it.....but you WILL need a rebuild......soon.

You can drive the car gently for awhile.....but it will never be a decent racer with that tranny in it's current state.

KW

Take it back, i did not want to hear that !

About 6 months ago , I had the Vigilante re-stalled to 3100. While it was in the shop waiting for the converter to get back , i had the guy pull the pan and check. Tranny had about 10 - 15 passes on it. pan looked clean , nothing unusual.

About a month ago i started using some drag radials, as the street tires were getting slippery at the track. But tonight, I used the street tires and noticed this issue.

Tell me it ain't so boss !!!! I can't go to SSH10 like this !


Also, I data logged the runs tonight, When it refused to up shift. it was banging around 6400. One time I even saw 6490.

I know I set the Box at 6200, but I think BH set the PCM at 6400.
 

·
Premium Member
Joined
·
20,353 Posts
Take it back, i did not want to hear that.......
I know......I'm sorry :( .

Check your tranny fluid to be sure you have enough, but the 3/4 clutch pack failure has GOT to be the most common 4L60e failure.

I had two trannies go out this way. With the second failure, I still drove it for 3 more months until I bought and installed a CPT tranny.

You can continue racing the car.....but you will subsequently notice the slippage get worse in normal driving.

I wish you luck, but.......

KW
 

·
Registered
Joined
·
551 Posts
Discussion Starter · #5 ·
Ok, talked to my tranny guy this morning, he agrees. :(



So , what's the FIX ? there's gotta be a replacement pack that will handle this abuse.

I re-counted the number of passes, About 20 on 1/4Mile and 15 on 1/8Mile. Plus about 2 years of DD.

All the other components were up graded on last rebuild, sunshell, servos, and I thought a decent set of clutch packs. Guess not.

The slicks did it, i just know it.

And my tranny guy is down with back problems. GEESH , does it get any better than this ???
 

·
Super Moderator
Joined
·
8,894 Posts
You may have some other problem like a leaky input housing or something that's causing the 3-4 clutchpack failure. How many miles are on the bushings? Did they get replaced on the last rebuild?

Or you could just replace the 3-4 clutchpack yourself.
 

·
Registered
Joined
·
551 Posts
Discussion Starter · #7 ·
You may have some other problem like a leaky input housing or something that's causing the 3-4 clutchpack failure. How many miles are on the bushings? Did they get replaced on the last rebuild?

Or you could just replace the 3-4 clutchpack yourself.
Left it up to my tranny guy, he's one of those GM certified people that have a shop on the outside.

So , can't really answer the bushing question, but did put about $600 in parts alone into it. and at the time thought what was going in was "the" parts to do. 2 years later I wish i kept the receipts :(
 
1 - 7 of 7 Posts
Top