Chevy Impala SS Forum banner

41 - 60 of 79 Posts

·
Registered
Joined
·
6,443 Posts
Discussion Starter #41
Now will this improve sound and power output or just help the electrical system run more efficiently?

Just curious about what this does as Im about to tear into my audio stuff...
efficiency.


IDK have any LT1 so I cant help you, it should still but im not sure.
 

·
Registered
Joined
·
466 Posts
on my LT1 imp. I dont know if im blind or just not seeing straight but i looked at my alt and there is no positive wire going to the batt other then the connector end and a ground cable? where do i have to hook up the positive to on the alternator that goes to the battery? thx
^ anyone know? im trying to start this quick project this coming weekend thanks guys
 

·
Premium Member
Joined
·
2,546 Posts
^ anyone know? im trying to start this quick project this coming weekend thanks guys
It goes to the post at the top, back side of the alternator. I can take a digital photo and post when I get home from work in 2-1/2 hours, if the description doesn't work for you.
 

·
Registered
Joined
·
466 Posts
from the look of the back of the alternator i only see the connector for the harness and the ground cable....i think i may have to take a better look at it tonight, if you can provide a pic it may help in what im trying to tell you guys thx
 

·
Registered
Joined
·
466 Posts
oh crap!
thats what i ment (i reversed what i was trying to say) i ment there is no NEG. bolt there do i just add one to the alternator? sorry guys i was confused on which one was missing. there is the harness to the right of the alternator and the POS bolt hook up but no ground correct? do i just add a bolt to there to ground it and ground it on the frame somewhere? thanks sorry for the confusion
 

·
Premium Member
Joined
·
2,546 Posts
from the look of the back of the alternator i only see the connector for the harness and the ground cable....i think i may have to take a better look at it tonight, if you can provide a pic it may help in what im trying to tell you guys thx
I had to work a little overtime tonight, and didn't get home 'till just now. Here's a pic of my alternator.


oh crap!
thats what i ment (i reversed what i was trying to say) i ment there is no NEG. bolt there do i just add one to the alternator? sorry guys i was confused on which one was missing. there is the harness to the right of the alternator and the POS bolt hook up but no ground correct? do i just add a bolt to there to ground it and ground it on the frame somewhere? thanks sorry for the confusion
Do you have a 9C1? The 9C1 has an auxillary post mounted to the fender well behind the battery
 

·
Registered
Joined
·
444 Posts
Well the positive goes there ^^^^^^^. The alternator case is the ground. The case grounds to the bracket to the block. Then the block is connected to the battery neg grounding it. You can add a ground straight from the alternator. I did it and just got a longer rear mounting bolt and attached it with a ring terminal.
 

·
Registered
Joined
·
466 Posts
got it, i figured i would just ground it to the case thx :)
 

·
Premium Member
Joined
·
2,546 Posts
Can anyone post a picture where they replaced the engine block to chassis ground?
I can do it when I get home tonight. Since I removed the AIR pump, I used one of the blind holes in that area of the engine block, up to the radiator support on top in front of the air filter box.
 

·
Registered
Joined
·
1,168 Posts
just use some 1/0 wire with a terminal on each end. i hooked mine to the lower alternator bracket seeing that the alt is where the power comes from so its the best ground on the whole engine
 

·
Premium Member
Joined
·
2,546 Posts
ok thanks
Sorry for the late reply. I had a long weeekend.

Here's the FT view:



Here's the top view (As a NOTE: I moved the opti-vent tubes out of the way, on the edge of the axhaust manifold for clarity of the picture only. After I took the pic, I moved them in front of the negative cable to keep it away from the heat source.):



The last, top view, showing the cable attached to the top of the radiator support on the LH side.

 

·
Registered
Joined
·
405 Posts
Please save yourself some money............. 120 buck? Damn!
 

·
Registered
Joined
·
39 Posts
Please save yourself some money............. 120 buck? Damn!
lol okay will do. how many feet should i get for the big 3?
 

·
Registered
Joined
·
284 Posts
3 feet should b good.
Can someone verify this?? for an 95Impala i dont think 3 feet "total" will be enough? anyone that has done this please pipe up!
 
41 - 60 of 79 Posts
Top